Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
I need to make it so when I call people my number is not listed or shows private. I can't find how to do it in the phone settings. Is there a way that it can be done on my account?
jaja87
Newbie

need to make it so when I call people my number is not listed or shows private.  I can't find how to do it in the phone settings.  Is there a way that it can be done on my account?

0 Likes
Re: I need to make it so when I call people my number is not listed or shows private. I can't find how to do it in the phone settings. Is there a way that it can be done on my account?
thatguyjohn
Enthusiast

Before you dial a number, type in *67, that blocks the other number from seeing who is calling. However, keep in mind that this has to be done before EVERY call. At this time, that is all I am personally aware of.

0 Likes
Re: I need to make it so when I call people my number is not listed or shows private.  I can't find how to do it in the phone settings.  Is there a way that it can be done on my account?
Ann154
Super User
Super User

There should be a way to set all your outgoing calls as private through your MyVerizon account online, but I don't remember the exact steps.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Re: I need to make it so when I call people my number is not listed or shows private. I can't find how to do it in the phone settings. Is there a way that it can be done on my account?
mama23dogs
Legend

The note 4 has a setting for this.

Ooen the dialer app.  Tap the  menu dots.  Select settings.  Select Call. 

Select 'more settings'

The first option is "Show my caller ID". 

Tap to change.   If you change that setting to "Hide..."   Your number will not show to people you call.

Re: I need to make it so when I call people my number is not listed or shows private. I can't find how to do it in the phone settings. Is there a way that it can be done on my account?
jaja87
Newbie

I followed all your steps but when I get to more settings the only options are tty mode and hearing aids

0 Likes
Re: I need to make it so when I call people my number is not listed or shows private. I can't find how to do it in the phone settings. Is there a way that it can be done on my account?
chris1060
Specialist

To set it in My Verizon, click on the menu (3 lines top left), go to My Profile & Settings, on the drop down, choose Manage Share Name ID, enter what you want to display on the receiving caller ID. Click Update. Your changes will be saved. It could take a few minutes for the change to take affect.

Re: I need to make it so when I call people my number is not listed or shows private.  I can't find how to do it in the phone settings.  Is there a way that it can be done on my account?
mama23dogs
Legend

Are you running lollipop?

0 Likes