Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
Cannot add corporate exchange email account
SMWAS
Enthusiast

Hi all,

I tried to add my corporate email exchange account to a new Z (actually I have tried on two different Zs), and I kept getting a popup that it needs a certificate.  My IT guy at work has no idea what it needs, and neither does the guy at the Verizon store.  When someone tries to add our corporate email from another Droid (say, a Samsung), this problem does not happen.  I currently have our corporate email running on my Droid Turbo just fine.

Any advice?  I would like to have this phone, but, obviously, not being able to run my corporate account for email/calendar/contacts is a non-starter.

Thanks in advance.

Labels (1)
0 Likes
Re: Cannot add corporate exchange email account
SoccerRef12
Specialist

I have added my corporate Microsoft exchange email without any issues. My Moto Z did not ask for a certificate. Sounds like a server issue?

0 Likes