1 2 3 Previous Next 61 Replies Latest reply: Nov 28, 2014 1:12 PM by rickdimaio RSS

    Motorola Razr Maxx losing wifi connection

    Greg_G

      I'm fed up with with my Motorola Razr Maxx losing its wifi connection to my home network.  I've been tolerating this problem since Android on my phone was upgraded to Jelly Bean about a year ago.  Prior to the Android upgrade I wasn't experiencing any problem.  I've had my Razr Maxx since August 2012.  I'm fed up with the problem and finally saying something because last week I received what's reported to be the final Android upgrade for the phone and the problem persists.  I'd been hoping an update would eventually solve the problem.  I'm not looking forward to tolerating this problem until my 2 year contract is up this fall.  When my contact is up and I comparison shop for phones and providers I'll definitely keep my bad experience with this Motorola phone from Verizon in mind.  Wifi is a very basic feature and there's absolutely no excuse for it not working.

       

      Wifi may work for a day or two but after that I'm left with a non-functioning wifi connection and a gray rather than blue wifi indicator on my phone's display.  I power cycle my phone to get wifi working again but after a period of time wifi will stop working again.  Based on the other postings in the discussion forums I'm not alone in having this problem.

       

      My router is a Linksys EA3500 using firmware version 1.1.39.145204 which is the latest version available.  This router was purchased on June 30, 2012 so it's only about 1 1/2 years old; definitely not an old worn out router than needs to be replaced.  The router also provides wifi connections for two windows laptops, two iPod touches, an iPad, a Wii, an iPhone, and a Roku.  These other eight devices have no problem maintaining a wifi connection so everything points to the problem being with the Razr Maxx.  Regardless, I tried a factory reset of the router but that didn't help the Razr Maxx's wifi problem.  I've also tried assigning the Razr Maxx a static IP rather using a DHCP address but that made no difference either.

       

      On the Razr Maxx I told my phone to forget my wifi connection and then I rediscovered and added my wifi connection back to the phone - that didn't make any difference either.  I've gone through the boot menus and cleared the cache partition but that didn't help either.

       

      I've tried everything that others have suggested but haven't had any success.  Any suggestions Verizon?

        1 2 3 Previous Next