3 Replies Latest reply on Feb 28, 2014 5:04 PM by abshaffer

    HTC One will not connect to my home wifi


      HTC one wont connect to my home wifi no matter what i try. Keeps comming up authentication error. I am positive im entering the correct password. Never had any issues such as this until i switched to this phone. Total piece of **** !!!

        • 1. Re: HTC One will not connect to my home wifi

          CALM down..


          Not the phones fault ..Reset and then Log in  to Router via your PC Review WI fi settings  and  resew/a  new pw.


          I do this all the time..w/o the histrionics.

          • 2. Re: HTC One will not connect to my home wifi

            BobD -- there is truth to what Mattb67 said.


            I recently bought the HTC One and my wife the Iphone 5. Neither would connect to my Actiontec GT724WGR modem/router, which is less than 4 years old. All other peripherals in my house connect just fine to that modem/router.


            I happen to know a lot about networks, and after resetting the router, trying different modes and channels, making sure firewalls were off, and trying a complete restore, and checking that firmware was latest, neither of those two phones connect to it with WPA or WPA2 security.


            Fortunately I had an old 2Wire 2700HG-D router in basement and the two phones connect just fine to that wifi. I since tried the Actiontec again, and still no-go.


            Unfortunately, that Actiontec modem/router has trouble connecting to modern cell phones via security methods that have been around for 10+ years. Quite ridiculous.

            • 3. Re: HTC One will not connect to my home wifi

              What fixed my HTC One was changing the encryption method of my wireless router for WPA-PSK from AES to TPIK. I discovered this was the issue by turning off the security on my router...the HTC One connected immediately. I then turned on the WPA-PSK with AES encryption and I received the same issue...the phone kept trying to authenticate over and over again as if a wrong password was supplied. Because I knew the password was 100% correct (all other devices in my house were connected and operating correctly with the same password), I figured it was the security (in this case the encryption type) that was keeping the phone from connecting. NOTE: I have an ancient Belkin router (Model: F5D7230-4). Good Luck! I hope this helps.