6 Replies Latest reply: Nov 18, 2012 7:19 PM by Minniehaha RSS

    Samsung Gusto 2 Prepaid


      I was just wondering how many others using the Verizon Prepaid service with the Samsung Gusto 2 have experienced their minutes just suddenly disappearing?


      I bought the phone on August 17, 2012 and it came with a $10 worth of  minutes. I added a $30 card on Oct. 3 2012  that was supposed to be good for 120 minutes and 3 months. I signed up with the 25 cents per minute plan because I do not use it that often. I received a text message from Verizon telling my my account was low. I go online and checked and found that I now have "0" minutes left.


      My online account shows that I've only used 3 or four minutes during the time I've had the phone. So what happened to my time and money?


      An update: I spoke with customer service on the phone and they said they have no record of my adding a $30 card. When I entered the card # I checked my balance via my phone and it showed that it had credited my account, I also received a text message from Verizon informing me that I had added the additional time and minutes. Unfortunately I threw the card away after entering it and deleted the text messages. I didn't see the point in keeping them, but I do now.


      I suppose that Verizon could wipe out everyone's time/minutes and simply claim that you never added any extra time. I would suggest to everyone who reads this to save your cards and write on them the date and rime you added it and keep your confirmation text messages. I have no doubt that there is a problem with Verizon's tracking system in regards to managing or keeping up with their customer's minutes.


      All I can say is that I am glad that I did not throw away my tracfone. My minutes roll over and every time I add a card the end time increases. You're never limited to just 30-60-90 days. Also, the time remaining and the end date are always displayed on the phone's screen. The book that came with my Verizon phone said that I could display this information on my Gusto 2 by going to Menu -> Settings -> Display -> Balance Display and highlighting the desired setting -> Show or Hide. Only problem is that I do not have a "Balance Display" option under "Display".