6 Replies Latest reply: Oct 14, 2012 1:09 PM by Holbrook RSS

    Problems connecting via USB with a MiFi 4620L

    Gulwulf

      I apologize if this has been asked before, but I could not find an answer. I'm trying to connect my new MiFi 4620L via USB because one of the programs I'm trying to use isn't working via port forwarding - it's an older program (Neverwinter Nights) so I'm not very surprised. I had no issues with it using a MiFi 2200 connected via USB on Windows 7 64-bit, but I cannot access the MiFi 4620L at all, nor the Internet, via USB. I have downloaded the driver files mentioned in the help file in the modem and Windows can see it. Do I need a special cable? I still have the one from the old modem, but I can upgrade that if needed. Thanks for your time.

        • 1. Re: Problems connecting via USB with a MiFi 4620L
          dimap52

          Hi, I don't have one of these, but I looked at the manual some time ago when it first came out, and if I remember correctly, USB Tethering has to be ENABLED via the admin access webpage in the router IP =10.1.1.1 or something like that.  I was interested in whether it could be tethered or not. There are several tabs of configuration options in the admin page, so I don't recall which one it was, but there was a tick box to check to enable the USB tethering support. You can google to find the .PDF for the manual if you need to, I apologize for being vague here, but as I said, it's been a while. Sorry!

           

          Oh, I also remember it saying there, that USB tethering is possible in Windows, Max OS X, and Linux. Yay!.

          • 2. Re: Problems connecting via USB with a MiFi 4620L
            Gulwulf

            Hey dimap52, thank you for the reply. I fixed my issue my assigning my modem a static IP. I was used to Verizon's Access Manager doing that automatically with the 2200, that I forgot I may need to do it with this one.

             

            Unfortunately, now I have a different issue. I've been trying to host a Neverwinter Nights (NWN) game, but others cannot access it. I was able to set up a Borderlands server using portforwarding and a WiFi connection (my wife and I both use the modem), but it appears that NWN does not want to work. Has anybody else had this issue? Thanks.

            • 3. Re: Problems connecting via USB with a MiFi 4620L
              Holbrook

              I'm hoping to tether my 4620L to a Linux machine which I would use as a firewall and for NAT. I read the same phrase about support for "Windows XP(SP3), Vista (SP2), 7, Mac OS X 10.5 or higher, Linux" but I am wondering if this is only for browser configuration support. A driver is supposedly required on the recipient machine to allow USB tethering (although it worked fine on my MacBook Pro without installing any new driver), and the driver versions are for Windows or Mac - none for Linux. Has anybody tethered a 4620L to a Linux box?

              • 4. Re: Problems connecting via USB with a MiFi 4620L
                dimap52

                On another forum http://www.evdoforums.com there is a comment thread about tethering this to Windows, and I saw a screen-shot there of the driver that is loaded and it is an NDIS driver (network) NOT a modem driver. This suggests that it should just "work" in linux using NDIS suppor built into the kernel. So I would just enable tethering via the checkbox in the admin page, plug it in and see if an NDIS network connection comes up in the Network Manager. This is what happened with my Razr M. An NDIS driver had to be (and was) loaded under windows for it to work there, but under Ubuntu it just connected using built-in NDIS support. Lovely.

                • 5. Re: Problems connecting via USB with a MiFi 4620L
                  Holbrook

                  Thanks for the response. With that encouragement, and the fact that it worked on OS X which is like Unix which is like Linux, I am downloading Xubuntu at this moment. I'll update once I get the project complete.

                  • 6. Re: Problems connecting via USB with a MiFi 4620L
                    Holbrook

                    FYI - Linux works fine with the 4620L via USB tether. No specific driver needed. Just plug it into a USB port and it shows up in Xubuntu as a network connection.