5 Replies Latest reply on Jul 13, 2012 8:21 AM by wherder

    Jetpack MIFI 4510L

      In November of 2011, I received a advertisement  from Verizon stating that I could upgrade my present Verizon

      Wireless Fivespot which is 3G for a Verizon Jetpack  4G LTE Mobile Hotspot MIFI 4510L free. I made the switch and

      used it in my home in Nebraska for about a month  and a half before going on the road in my motor home heading to

      California for the winter. From the start, I have  had problems with the MIFI disconnecting from the internet.

      Constantly. Access will go from "Local and  Internet" to "Local only" or "Connected with limited connectivity".After

      fiddling with connect/disconnect which sometimes  takes anywhere from a few seconds to a couple minutes, I may

      regain a connection. It is very frustrating when  trying to pay bills on line or fill out forms, etc. When I arrived

      in CA, I went to a Verizon store and eventually got  them to order me a replacement. Same problem. I am now on my

      third replacement (fourth MIFI) and another  replacement is on the way as I write this. I'm a 13 year veteran of

      Alltel/Verizon and have not used any other wireless  service. I asked the rep at Verizon if I could get the latest

      Jetpack 4620L since the 4510L wasn't working. I  thought I had an agreement to get one as a replacement with just an

      extension of the two year agreement, but then I was  told I would have to pay a reduced price for it. I didn't go

      for it, so now a 4510L replacement is on the way.  Another problem with this device is the constant switching

      between 4G and 3G. I've been parked in the Monterey  Elks Lodge parking lot since Dec 26th and the light blinks

      green when 4G and purple when 3G. It goes back and  forth continuously. At one time or the other, all devices that I

      have had have had the firmware upgraded at the  store and at least two sim cards replaced. Two trouble tickets were

      issued, the first lost and I've not been contacted  about the second one although it's been a couple weeks since the

      second ticket was issued. There seems to be some  serious design or manufacturing problems or both with the 4510L.

      It looks as if I'm going to be stuck with this  device unless I want to just dump it and take my penalty. Is there anything else that I can do?

        • 1. Re: Jetpack MIFI 4510L

          log into the 192. address and change it to 3g only, sounds like you are in a fringe area

          • 2. Re: Jetpack MIFI 4510L
            John Getzke

            I think your best chance of improving your experience is by updating the firmware to 2.28.  Make sure when you recieve your new MiFi that it is up to date.  VZW store reps can perform the steps for you if you cannot keep your connection open long enough in the field.  Let us know if you need steps for looking up the FW version or completing the update.


            2.28 has been reported to be very successful when dealing with the 3G/4G LTE handoff situation.  If that doesnt clear up enough of the problems then switching to 3G only would be the next best step.  The MiFi can hand up from 3G to 4G LTE without disconnecting but not the other way around.  Once your connection is stable in one mode or the other we can continue to isolate any remaining disconnection issues.

            • 3. Re: Jetpack MIFI 4510L


              After I sent the message below, I received my replacement MIFI and on the plastic sleeve that it was in there was a decal which
              among other info on it stated that the firmware was 2.28 so we'll now see if
              that solves my problem. I went to the 192 site and verified that the FW is indeed
              2.28. Will let you know how this new (reconditioned) device works.






                I tried switching to 3G only and it work for quite awhile, but then started dropping the connection. It was obviously a lot slower with 3G. Went back to 4G and into the 192 site and checked for new updates. It says that there are no new updates available. I had the Verizon store update the Jetpack when I received it as my third replacement. The 192 site shows an AP FW version 2.10- and a modem FW version 2.23.01. I think the later is the one you're talking about. If it is, then I guess that I'll have to take it back and specifically ask them to upgrade to 2.28. Still waiting on the next device. Thanks for your help.



              • 4. Re: Jetpack MIFI 4510L

                I have give up on mine and will just have to eat the monthly rate plan charge but my device is in a box ready to go back. Thank goodness a Rep offered me the new share plan and personal hotspot option on my cell phone so I have internet through them

                • 5. Re: Jetpack MIFI 4510L

                  FWIW, when I ditched my 4150L (which I still have, but don't have service on it) and instead got a v3 iPad with LTE, ALL of the issues I experienced with the 4150L disappeared immediately.  Still connecting with the same PCs to the hotspot, same sites, same locations, same times, same usage. 


                  I had previously replaced the 4150L, new SIM, firmware updates, MANY MANY hours with Verizon support.  Nothing worked.  Shutting the device off and replacing it with a different type device instantly worked.


                  I use the device in (just to name a few):  Pittsburgh, Boston, New York, Philly, Cleveland, Columbus, San Diego, San Francisco, Austin, Detroit, Chicago......


                  Same experience (both related to 4150L and the iPad) in every single location.  It is NOT tower dependent.  It is NOT location dependent.