2 Replies Latest reply: Jun 1, 2012 9:30 AM by dollarbang RSS

    Google Play not working

    jallen

      Hi, I tried downloading an app from Google Play but all I get is a gray screen saying loading and then connection timed out. How do I get it to work? By the way if I need a Google account it is already synched to the phone.

        • 1. Re: Google Play not working
          dollarbang

          Do you have your Android setup for WiFi? I have found (and I'm a newbie with a Droid RAZR) that Google Play uses WiFi connection to download (could have been a requirement, then again...I may have flagged all downloads to use WiFi)...

           

          Hope this helps.

          • 2. Re: Google Play not working
            dollarbang

            Oh, and another thing, I'm having issues too with Google Play. It is only working from my Droid. The Web Link is giving me an error that I don't understand.

             

            "You haven't accessed the Google Play Store app (the white shopping bag app icon) on your device with this email account."

             

            It worked several days ago. The difference today is that I refreshed my Droid to factory (someone suggested that when I kept getting SMS messages from Verizon and turn off account backup using Backup Plus). I have completed most of the reinstallations of APPs I was using, but I have had to use the shopping cart on my Droid.

             

            Good luck

             

            Message was edited by: Harold Ayers...I just checked Google's Website for Android Apps on Google Play issues log. "Error processing purchase" on free apps We've had a few reports from other users of an "Error processing purchase" on all download attempts. We're currently investigating a more permanent solution, but in the meantime, please try the following to resolve the issue: - Navigate to Menu > Settings > Applications > Manage applications (on Android 4.0 devices, Settings > Apps) - Navigate to the "All" section - Scroll down to find an app called Google Services Framework - Select Google Services Framework, then tap Clear cache and Clear data