5 Replies Latest reply: Jan 2, 2013 9:36 AM by gapus RSS

    Exchange: Couldn't open connection to server

    Nitsuj

      This has happened a few times now with the stock Email app accessing an exchange server.

       

      Initial setup works just fine, email, calendar, contact syncing works just fine then after a few weeks it stops working and throws this error.

       

      The only solution I have found that works is to remove the account and readd it. This is not a long term solution and is highly annoying.

       

      Suggestions on a permanent fix are being sought

        • 1. Re: Exchange: Couldn't open connection to server
          2bella

          I also had the same problem a couple of times on my Galaxy Nexus.  My initial set up worked fine just as you mentioned, however after a few weeks I would get the same error.  I also did the same to un-install and re-install but it was a temporary fix.

           

          I then changed the sync options on "days to sync' from 'one month' to "All", now it seems like everything is syncing.  I no longer get that error.  I think that the "one month' sync was the limitation because the problem occurred from when I reached about a month of emails in my inbox.  Hopefully this was the solution and maybe this will work for you?

           

          Good luck and I will keep you posted if my solution fails.!

          • 2. Re: Exchange: Couldn't open connection to server
            commonsense101

            The app touchdown works great

            • 3. Re: Exchange: Couldn't open connection to server
              renvorak

              I have received this error from day on (December 2011) and it's been driving me crazy.  I switched from an iPhone 4 which was flawless with Exchange 2010.  The only way that I have been able to make it work is to use Touchdown, but I would prefer the native support with direct integration on calendar and contacts.

               

              From what I have read, this seems to be an issue with Android 4.0 which has been addressed in 4.0.4 (SD card encryption), but in typical VZW fashion, there is no word on a release date or the fact that it is even being considered.  I believe 4.0.4 has been out for a couple months now.

               

              Here is the link with many others having the same problem:

              http://code.google.com/p/android/issues/detail?id=22975

               

              What version of Exchange server are you guys using that has sporadically worked?  I'd take that at this point, but as each day goes by, I miss AT&T and the iPhone more and more....  I hope VZW will release the update that will hopefully fix this and other issues (random locking up, waking up to a phone that has been locked up all day, poor 4G reception, poor battery life, etc.).

               

               

              Renvorak

              • 4. Re: Exchange: Couldn't open connection to server
                cmptrsally

                THIS NEXUS IS THE CRAPPIEST PHONE I HAVE EVER OWNED!       I have been with verizon for YEARS and never had so many problems with any of their phones or their customer service.  I can't tell you how many times I have had to call them for one thing or another with this stupid phone!  I want to go back to my Droid X  at least I got better service and everything worked just fine on it.  Why i ever changed....  I don't know!   As a couple of you said, entering the cooperate account the first time worked, after that....  NOTHING!  i had their techs walk me through it again and still nothing!  Very Dissapointed!

                • 5. Re: Exchange: Couldn't open connection to server
                  gapus

                  I have this problem when wifi is on and there is a portal that has to be logged into in order to get internet connectivity.  For example, at work, you have to go through a browser and enter login credentials to enable network access and then you have internet access through through the local wifi.  I assume the problem is the phone default to using wifi when it can connect to the access point but unless it can get internet access through the access point connection, it just keeps this default and does not revert to using the cell connection, thereby sitting in limbo.