1 2 Previous Next 14 Replies Latest reply: Jun 7, 2012 5:22 PM by Verizon Wireless Customer Support RSS

    USB Not Recognized

    crystallet

      I connected my Droid Razr to my Win 7 laptop and got a message that the device was not recognized.  I rebooted both, nothing.  Win 7 keeps telling me that my device is not recognized and I should replace it.  Gee, thanks, Microsoft.  The USB cord I used was not the cord that came in the Razr box, which is too short for my setup, but I did buy the cord from Verizon.  Has anyone else had this problem?  Does anyone have a solution?

        • 1. Re: USB Not Recognized
          SteelerFan

          Mine is seen no problem. Try deleting it from device manager and try a different port. Also go in to storage manager and try changing drive letters for laughs. It should see it.

          • 2. Re: USB Not Recognized
            Wildman

            Did you install the drivers for the device because without them installed usually cause the issue you are seeing?

            • 3. Re: USB Not Recognized
              SallyC

              I am running Windows 7 64 bit and have no problem.  I would try a different USB cord and a different USB port on your machine.  Be sure you are not going through a USB hub.

              • 4. Re: USB Not Recognized
                Emily_Rose

                Everyone, thanks for your answers.

                 

                I'm not using a hub, and I tried switching USB ports.  That didn't work.  What did work was using the cable that came in the box with the phone.  The additional cables I bought from Verizon don't work.  Without installing anything, but using the cable that came in the box, I plugged the phone into a different Win 7 64 bit laptop, and the computer immediately recognized the device and installed the drivers.  Although the cables I bought say "data cables," apparently they're only chargers.  Oh, well...

                • 5. Re: USB Not Recognized
                  spaberlejr

                  Never would have thunk it ! Spent 4 hours trying to fix this then used the original USB cable that came with the phone and Voila ! it works !

                   

                  I guess al USB cables are not made the same ....

                   

                  Now to fix the MOTOCAST USB problem ....

                  • 6. Re: USB Not Recognized
                    crystallet

                    I never would have thunk it, especially since the Verizon cable is advertised as a "data" cable.  And, just to wrap up all the loose ends, I took the cable that came in the box and connected the phone to the original computer that would not recognize the USB device, and guess what??!!??  Just like with my home laptop, the phone was instantly recognized, drivers were installed, and everything worked just fine.

                     

                    So I have a new question:  has anyone had success connecting the phone to a Win 7 64 bit laptop using anything other than the cable that came in the box?

                     

                    Everyone, thanks for your help!

                    • 7. Re: USB Not Recognized
                      SallyC

                      Yes.   I used a longer cable I got from Amazon and it worked fine.

                       

                      Well, maybe not as fine as I thought.  I have a battery app that was always reporting a 99% charge.  After your post, just for grins, I connected the cable I got with the phone and the app then reported 100% charge.

                       

                      So it's an interesting question - how can you assess a micro USB before you buy it?

                      • 8. Re: USB Not Recognized
                        AngusPT

                        Had the exact same problem, used the verizon cable from my Droid x, charge only, no usb support, device not recognized, hair pulled for two days..... changed cable, solution, What is the difference? How can you tell  Never had an issue like this with cables that fit and look the same.... Thanks for the help. 

                         

                        • 9. Re: USB Not Recognized
                          TnTransplant

                          The cord may be your problem, but is definitely NOT my problem. I believe it is a Windows 7 problem.

                          Nothing at all happens now when I plug two different factory Motorola (from the box, original Droid and Droid Razr) cords into my 64 bit Windows 7 Home Professional laptop.

                          Tethering and USB storage used to work fine and reliably on this laptop with these cords.

                          Then it became intermittent.

                          Then it stopped, not unrecognized, just NOTHING, no bonk, no recognition that anything was plugged in.

                          Here's the kicker. This machine can dual boot Vista on another partition.

                          When I boot into Vista on this SAME machine and SAME cables, everything works fine, tethering, USB, all.

                          Then, I rebooted Windows 7 and same thing. Instantly recognized all working fine.

                           

                          Thoughts?

                          1 2 Previous Next