2 Replies Latest reply: Oct 24, 2011 9:10 PM by ArnettH_VZW Branched to a new discussion. RSS

    SIM Card not registering on phone?

    k8m0nst3r

      The backstory:

       

      I dropped my phone in the toilet, bought a brand new one. Activated it and all that last night.

       

      The problem:

       

      Calls, texts, apps all work fine... but it says there is no SIM Card so i can't take pictures and what not.

       

      I have the old card (which probably doesn't work). And the new one (which should work!) and neither is registering with the phone. What's going on? :smileysad:

        • 1. Re: SIM Card not registering on phone?
          SuzyQ
          We'll need more information - what phone do you have? And do you mean SD card (memory card, to save your photos, music, etc on)?

          Is the new card you are trying to use the same capacity as the old one? You may need to format the card to work in the phone the first time.

          Most phones will allow you to save pictures to the internal memory of the phone; you may have your phone set to save to the card, which it can't find just yet. Try changing the settings to save to the phone, get the card issue straightened out, then redo the settings to save to the card.

          HTH,
          • 2. Re: SIM Card not registering on phone?
            ArnettH_VZW

            Hello k8m0nst3r,

             

            Thank you for sharing your concern with the community as I am eager to assist you. May I ask what make & model device do you have? I agree with SuzyQ. In order to assist you we would need more information on the topic. If it's a 4G SIM card then the original that went into the toilet will not work. If you have a new SIM card and it's not working then please reply with the error message that you are getting when you try to use your service. If it's a memory card issue then I would recommend trying the steps that SuzyQ provided in her posting. Let us know if any of these recommendations work for you.

             

            Thank you...