1 Reply Latest reply: Jul 11, 2011 5:48 PM by WCMack RSS

    Droid Charge "non-supported battery"

    Jerry_VW

      I recenly started receiving a maeesage when I try to charge my phone.  I get a message of "non-supported battery".  I know my batteries are supported, they are the original batteries I purchased from the Verixon store when I bought my phone and they worked fin , THEN.  I had no issues until I messed around with Task Manager.  Did I clear something that  I should not have cleared.  Now I cannot put my phone in my desktop charger cradle with out the message, and it will not charge.  How do I fix this?

        • 1. Re: Droid Charge "non-supported battery"
          WCMack

          Have you tried a hard reset of the phone?

           

          Here is the method copied from VerizonCellphones.org...

           

          Tips: how to hard reset Samsung Droid Charge

          Preferred method

          1. From the home screen, select Applications.
          2. Select Settings.
          3. Select Privacy.
          4. From the Personal data section, select Factory data reset.
          5. Select Reset phone.
            NoteIf presented, enter the current passcode or draw the unlock pattern.
          6. Select Erase everything.
            NoteAllow up to 2 to 2 1/2 minutes for the factory data reset and reboot processes to complete.
          7. Refer to Initial Activation and SetUp if necessary.

          Good luck.