1 2 Previous Next 10 Replies Latest reply: May 16, 2012 12:23 PM by Dan1976 RSS

    Can't connect to secured WiFi Network at the Office

    parker63

      I've checked around and have only seen a problem similar to mine in a home environment, where you would be able to see your router and make some adjustments.  This is a problem in regards to a corporate environment.

       

      I have a Motorola Droid, with the original 2.0 firmware.  I'm trying to used the WiFi secured network that is in my office.  To use it here, we usually have to login with a username and password.

       

      On the Droid, the network is seen as available, but when tapping it to try and enter in my data, all it asks for is a WEP hex code.  I type in my password that I usually use, but it always comes back as "unsuccessful."  I can set this up with either a desktop or a laptop with no problem, however, I can always enter my username along with my password.

       

      I asked one of the I.T. guys here in the office about it, but all he could tell me was that Blackberry and iPhone could do this all the time, and uses username and password to login.  He said he didn't know what the deal was with the Android OS. :smileysad:

       

      Is there an app available for the Droid so that I can enter in both a username and a password in order to log on to my office's secure WiFi network?  Am I missing something simple in the WiFi setup in order to use both a username and a password?  Or am I stuck with 3G while in the office environment?  Thanks.

        • 1. Re: Can't connect to secured WiFi Network at the Office
          logicman

          What does it say under the SSID for your office WiFi network in WiFi settings? This should list the security protocol being used. Seems unlikely they would be using WEP since it is the least secure protocol. Also, touch and hold the SSID in WiFi settings. Depending on the state of the connection you may see Forget network. If it's there touch it. It should then prompt you for pertinent info next time you try to connect.

          • 2. Re: Can't connect to secured WiFi Network at the Office
            parker63

            That's just it...the office uses Enterprise 802.1x security, but according to the Droid and what WiFi networks it "sees" in the office, it says it sees the appropriate SSID (companyname-secured-network) and then underneath it, it says "Secured with WEP" which is totally wrong.  When trying to connect, it then just asks for that WEP hex code, which doesn't work either.

             

            I tried manually adding the network with the SSID, but then it says "not in range" so that doesn't do it either.  That's why I'm trying to figure out.  Coworkers with iPhones and Blackberry's can get on with no problem, but I can't, and for some reason, the Droid's WiFi sees the network, but with the wrong type of security settings.  Totally weird.  That's why I was wondering if there was a third party WiFi app that might resolve this issue, since the built-in WiFi doesn't seem to be working right here.

             

            BTW, the WiFi works perfectly fine at my house, but not here at work.  And I've got a WPA-2 secured network setup at home.

             

            Thanks for whatever info you can provide.

            • 3. Re: Can't connect to secured WiFi Network at the Office
              tsauter

              Did some googling and here are some links I found.

               

              https://supportforums.motorola.com/thread/16684

               

              Here is one that details the steps involved.


              http://8help.osu.edu/4254.html

               

              Hope these help. Maybe you will need to find out what option (eap, peap, ca etc.) from your IT dept.

              • 4. Re: Can't connect to secured WiFi Network at the Office
                parker63

                Thanks, I was just reading that Ohio State page after doing some more searching around, then got a notice of your post....

                 

                When I try manually entering in the SSID though, I keep getting a "Not in range, remembered" notice in the Wi-Fi networks list.  The original SSID does appear as available though, but it's the one that says "Secured with WEP" then asks for a WEP hex key.  No user ID option anywhere.  Oh yeah, and it says signal strength before connecting as "Excellent" which is just more salt in the wound.

                 

                The other Motorola Forum link talks about needing a .p12 certificate file from the I.T. guys and putting on my Droid's SD card.  And I don't even know if our office uses .p12 files or not.  Sure seems to be a lot of hoops to jump through when other phones in the office "just work" and the Droid doesn't.

                 

                No, it's not life or death, and if necessary I can use 3G if I need it, but it is kinda weird, and one of the reasons I got the Droid in the first place was because of the built in WiFi capability.

                • 5. Re: Can't connect to secured WiFi Network at the Office
                  logicman

                   

                  My office network also uses 802.1x. As I recall it took a couple of tries before it connected. If you touch and hold the network name in Settings is, do you see Forget network? Try that so it will prompt for ID and password again. As I recall just prior to my first successful connection I got prompted to create a password for certificate storage. Then it displayed a connect screen which had EAP method as the first drop down along with entry fields for Identity and Wireless password.

                   

                  • 6. Re: Can't connect to secured WiFi Network at the Office
                    parker63

                    Tried doing the "Forget Network" suggestion, but it didn't give me that option in the popup.  Apparently the phone will only let you forget the network if the network is out of range(?)  Not sure about that theory, but it for sure didn't give me an option to forget the network.

                     

                    Meanwhile, I have found another page from Google about Android, WiFi and corporate networks.  Unfortunately I'm not the only one who is having problems.  It may not be exactly the same problem I'm having, but it revolves around WPA2 Enterprise support, or lack of it.  The last post on the board was on 12/5/09, so it's still topical.

                     

                    What I am now curious to find out is, with the recently released 2.0.1 update for the Droid (I haven't received it yet) I'm wondering if that might fix the problem?  Just really weird.  Especially since I was able to set up Exchange on the Droid without too much trouble (had a few quirks at first, but eventually worked) but can't get WiFi.  I would have thought picking up the office's WiFi system would have been easier than setting up Exchange, but that's been my personal experience.

                     

                    I'm leaving this open as "unresolved" for the moment, but I appreciate all the suggestions so far.  Thanks folks.

                    • 7. Re: Can't connect to secured WiFi Network at the Office
                      parker63

                      It appears after much Google searching on this issue, it is a matter of the Android OS, not the Droid in particular.  In short, Enterprise 802.1x connectivity is not fully supported on the Android platform (yet.)  If you do a search on Google for "Enterprise 802.1x" and "Android" together you will find dozens of discussion groups talking about the same thing.

                       

                      Examples:

                      http://androidcommunity.com/forums/f7/getting-wi-fi-at-college-12857/

                      http://www.howardforums.com/showthread.php?t=1595223

                      http://code.google.com/p/android/issues/detail?id=1386

                       

                      A few folks have talked about adding support by rooting their phone, but I don't want to venture into that territory.  Should someone come up with a simple app that can resolve this problem, I will definitely download it.  If the Android OS developers figure out a way to add support for this protocol in the OS, I'll be extremely happy.  In the meantime, it appears that (if what I'm reading online is correct) this is a shortcoming of the Android operating system, not the Droid itself.

                       

                      :smileysad:

                      • 8. Re: Can't connect to secured WiFi Network at the Office
                        Repairman

                        This thread is old. But the most active I've found on this board.

                         

                        And here it is... End of Jan, 2010 and Verizon still has not fix this problem.

                         

                        Something has got to be done!

                         

                        I am a network admin who bought this Droid a855 phone after a lot of research. Apps that allowed me to control my Unix/Linux/Windows servers. SSH tools. Geek toys. A open source OS. Etc. The whole package looked great. And with it I could be productive while not tied to my desk.

                        Hang out in my environment control server room. Which is noisy as all get-out. No problem. This would do it all for me.

                         

                        Bought the phone, installed the apps, and was able to tie into my high security access points at the office and my home (My home network is tied by VPN into my office because I do as much work, it not more, from home). Then the next day the phone told me to update the software. And everything has been down-hill from there.

                         

                        Can't use WiFi unless it's a open access point. Even pitiful WEP encryption won't work. They broke everything about the phone I bought it for. And when I looked into the problem, I see that I missed the fact I should have never installed the software update. Although somewhere I read that it was going to be forced anyway.

                         

                        I've sent a message to Verizon support from my online verizonwireless.com account and have not received any reply. And it's been almost a week. Verizon does not even have the common courtesy of saying "We're looking into it". Or even "xx/xx/xxxx a patch will be out.

                         

                        After I finish this post, I'm finding out the return policy for the handset. My old LG VX-4400 still works fine (actually better in some ways. It get's better signal than the Droid) and they will just have to take the loss of the additions I've added to my air-time package.

                         

                        If they can't even give me a time frame when the Droid will be fixed. Or be courteous enough to send any reply at all to my message. Verizon's not a company I want to be doing business with. Even if their coverage map (faked or not) is better than the other carriers.

                        • 9. Re: Can't connect to secured WiFi Network at the Office
                          Scotty_BMD

                          See..I am having a similar difficulty. If I am not close to an open access point, I, too cannot access WiFi. And heck, that is why I bought a phone like this one. I chose this one because it had a regular quwert keyboard in addition to the touch key board. As I have bad arthritis in my hands, I felt I should have the option of sticking with the qwerty keyboard..I like the razr, but was afraid of the keyboard. I now know better on that front. I wanted a smart phone to have easy accessy to the net while on a long trip I just took - and have found it to be less than stellar.

                           

                          My 2 biggest complaints are the battery life or lack there of..and the difficulty with wifi if I am not sitting near an open access point. Not sure I can exchange the phone for a different one as I have had it since January 2012.

                          Thanks for listening.

                          Scotty_BMD

                          1 2 Previous Next