New problem with Galaxy S10? (Hotspot.)

gregoryostrom
Member

   I picked up 2 brand new Galaxy S10+ phones Friday evening. We ported in from Sprint (so nice to be back with Verizon after 13 years of Sprint btw), but I picked up the phones from the local Verizon store, so these are not Sprint phones. The phones and service work flawlessly, except for the hotspot. When I try to turn the hotspot on I get an error that says "Mobile number not found."

   I went through basic and tier two tech support and have tried everything, including a factory reset. Tier two tech support sent me to the Verizon store to pick up two new phones (both phones are having the same problem).

   The store and 3 employees worked for over an hour trying everything including a new SIM card, but they were baffled and couldn't fix the problem. We were all skepticall that two phones would be bad like that at the same time. The manager even put my SIM card in his phone (it wasn't a Galaxy S10) to see if it had something to do with the new account / port. He had no problems turning on his hotspot with my account on his phone. They got a brand new S10+ out,  put my SIM card in it and no dice. They thought it might be the last software update, but the new phone hotspot wouldn't work before any updates were installed.

   Has anybody else had this problem recently, or does anyone have any suggestions? Everything works perfectly other than the hotspot. 

Who I have the same questioned this topic