Highlighted

How do I receive my texts as iMessages?

Maraude
Member

Greetings,

I had my iPhone 4s and DH's 4s side by side right now trying to figure out why I am missing a boatload of messages coming from DH's iPhone since yesterday morning.

What I know:

1. DH upgraded to OS 7.1 yesterday (as per settings in phone) Not sure what the OS was before that, but not a 7.x for sure.

2. Before the upgrade, no problem; iMessage or SMS was making it through without a hitch.

2. I connect to cellular data and  wifi as needed

Here is what my troubleshooting made me conclude after trying all possible combinations:

A. DH sends SMS (Text Message as labeled on the screen) by turning off cellular data and wifi which is usually has on at all time unlike me > I get the message labeled as a Text Message myself whether or not I have either cellular data or wifi on or off. No problem at all.

B. The trouble appears when iMessage makes its entrance: DH turns has Cellular data or wifi on, which switches him to iMessage as per screen label > I get the iMessage ONLY when I turn on my data (cellular or wifi); when data is off, the iMessages get queued somewhere in binary land.

This is a major draw back since I don't want mine on all the time as I have a very limited amount of data for financial reasons.

So, my question:

Without DH having to go through the rigmarole of turning off his Internet pipe to communicate with my iPhone via SMS OR me turning on my data at all time to get the iMessages right away, how do we fix this annoying quirk?  In other words, how to force SMS/Text Messages over iMessages when talking to other iPhone even when cellular data or wifi is on?

Thank you for your time.

Labels (1)
0 Likes
1 Solution

Correct Answers

Re: SMS vs iMessage - iPhone to iPhone

Maraude
Member

I just figured it out.

If you want cellular data turned off, just disable iMessage:

Settings -> Messages -> iMessage Off.

View solution in original post

0 Likes

Re: SMS vs iMessage - iPhone to iPhone

Maraude
Member

I just figured it out.

If you want cellular data turned off, just disable iMessage:

Settings -> Messages -> iMessage Off.

View solution in original post

0 Likes