Highlighted

How do I add mail server to vtext.com whitelist?

I have 3 servers I use to monitor various services and equipment that send out short messages to 2 Verizon phones using the phonenumber@vtext.com email to text service.

Starting today I noticed at least one of them getting this in the mail logs:

(host smtp-bb.vtext.com[69.78.128.213] refused to talk to me: 554 njbrspamp1.vtext.com)

Basically my server's IP address has been blacklisted and I can no longer send text messages from this server.

Is there someone or some place I can whitelist 3 IP addresses so my servers can send me and another manager alert messages?

Thanks!

Labels (1)
0 Likes
1 Solution

Correct Answers
Highlighted

Re: How do I add mail server to vtext.com whitelist?

Replying to my own message with a fix that has seemed to work for me.

First I'm using Ubuntu Linux, Bind and Postfix, so these are the setting for those.

Basically you need to have several things properly set so other mail servers will recognize your mail server as legitimate.

These things include:

SPF record

hostname

reverse DNS hostname/lookup

So say your server has an IP address of 33.33.33.33 and you have it called myhost.host.com

Reverse DNS lookup: You need to get with who is providing your IP addresses and match a lookup of 33.33.33.33 to show myhost.host.com. Or alternately you can see what 33.33.33.33 shows already and change your server hostname to match that.

In your Bind DNS record set the following, update and restart Bind:

myhost           IN  A  33.33.33.33

myhost           IN  TXT "v=spf1 a mx ip4:162.243.81.17 a:myhost.host.com mx:myhost.host.com ~all"

myhost           IN  MX 10 myhost

On your server set postfix/mail server to use myhost.host.com as your hostname so outgoing mail sent from command line programs will give the proper from address also set it to display the proper info to other servers it connects to:

postconf -e smtpd_banner="myhost.host.com ESMTP \$mail_name"

postconf -e myhostname=myhost.host.com

service postfix reload

View solution in original post

0 Likes
Highlighted

Re: How do I add mail server to vtext.com whitelist?

Member

Im having the same issue.  Cannot send any emails to phones using the phone number@vtext.com either through our work email servers or even Google email or Yahoo.

0 Likes
Highlighted

Re: How do I add mail server to vtext.com whitelist?

I'm currently doing a workaround by sending mail to another server and having it forward with an alias to my phone. I need to just get on with customer service I guess and see if they can get me to the proper people to whitelist if that is even possible?!?!?

Sounds like you may be having other problems if Gmail won't get mail/text through to it. Are you getting an error message back when you try and send to it from Gmail?

0 Likes
Highlighted

Re: How do I add mail server to vtext.com whitelist?

Member


Nope, no bounce backs.   we have tried sending vtext to our company phones through work email / gmail / and yahoo.

0 Likes
Highlighted

Re: How do I add mail server to vtext.com whitelist?

Member

Found out that the accounts had gotten a checkbox for Internet Spam Blocking for  "Block all text messages sent from email".

0 Likes
Highlighted

Re: How do I add mail server to vtext.com whitelist?

Replying to my own message with a fix that has seemed to work for me.

First I'm using Ubuntu Linux, Bind and Postfix, so these are the setting for those.

Basically you need to have several things properly set so other mail servers will recognize your mail server as legitimate.

These things include:

SPF record

hostname

reverse DNS hostname/lookup

So say your server has an IP address of 33.33.33.33 and you have it called myhost.host.com

Reverse DNS lookup: You need to get with who is providing your IP addresses and match a lookup of 33.33.33.33 to show myhost.host.com. Or alternately you can see what 33.33.33.33 shows already and change your server hostname to match that.

In your Bind DNS record set the following, update and restart Bind:

myhost           IN  A  33.33.33.33

myhost           IN  TXT "v=spf1 a mx ip4:162.243.81.17 a:myhost.host.com mx:myhost.host.com ~all"

myhost           IN  MX 10 myhost

On your server set postfix/mail server to use myhost.host.com as your hostname so outgoing mail sent from command line programs will give the proper from address also set it to display the proper info to other servers it connects to:

postconf -e smtpd_banner="myhost.host.com ESMTP \$mail_name"

postconf -e myhostname=myhost.host.com

service postfix reload

View solution in original post

0 Likes