Re: s8 and wifi calling notifications

CBRadio
Member

Running on a Samsung S8+ ... I want to use wi-fi calling, as we have no cell signal at my office.  However, Im' experiencing the same nagging notification issue others have reported.  I have enabled WiFi calling, I've cleared storage for the WiFi Calling App as recommended earlier, and I've verified the permissions are enabled on both the Advanced Calling and WiFi Calling apps.  My emergency address is set.  Despite this, the notification prompt continues to come up.

Does anyone know what actually triggers that notification?  Since it's first action when I hit it is to prompt to update my address, I'm wondering if it's triggered by something location/network related, perhaps detecting that the MAC address of the WAP has changed (corporate environment, so there are several WAPs in range at my desk, all on the same SSID).  I'm curious because I don't notice it popping the prompt at home, where the connected wifi is via a single WAP with strong signal.  Or perhaps it's only popping the option when it sees the LTE signal drop from "nearly non-existent" to "really non-existent"?

0 Likes

Re: s8 and wifi calling notifications

Marvane
Member

THIS DOES WORK ~! . swipe LEFT! on wifi calling notification bar on startup screen , tap gear cog then ignore on off switches ,  go down and tap the 3rd or fourth option down (sorry not sure which one because once i turned it off its off so i couldn't go through it again to see,  but it is not either option with a blue "on/off" slider on right it is just an option in type you tap and it opens)  and it will let you hide, use or (" do not show notifications") ,  tap "do not show notifications" and the turn on screen will no longer have the infuriating wifi calling notification. lol

0 Likes

Re: s8 and wifi calling notifications

CBRadio
Member

That might work (certainly gets rid of the annoyance), but since I'm dependent upon wi-fi calling working properly, I don't want to just ignore the notification if it's serving a purpose - i.e. if it's saying "You're dead in the water until you take action" then I still need to see it so I can take that action. 

As I mentioned above, I only seem to encounter this at work, I've never seen it prompt at home.  The two differences between those locations are:  1) home has a strong LTE signal, work has a nearly non-existent one (but not completely).  2) home has a single strong WAP, work is an enterprise with multiple WAPs, generally with good overlap.  My working theory is that I may be getting the prompt at work when LTE becomes unusable (i.e. as I walk around, people move, etc. that causes a signal drop to zero).  Will test tomorrow by putting the phone in airplane mode and then re-enabling wi-fi to see if it stays stable, or perhaps throwing some signal monitoring on there.

0 Likes

Re: s8 and wifi calling notifications

CBRadio
Member

Tested at work for a few days and the working theory seems solid - when wifi is enabled & connected, the phone prompts to enable wifi calling (even though it's already enabled) every time it loses the LTE signal.  When I put the phone into airplane mode & manually re-enable wifi, the prompting goes away (and wifi calling works fine).

I was going to program Tasker to just handle this going forward, but a new update dropped yesterday and I've yet to see a wifi calling prompt ... is it too much to hope that they actually fixed it?

0 Likes

Re: s8 and wifi calling notifications

CBRadio
Member

Guessing that they finally fixed it, because after the update I've never received another prompt.

0 Likes