s8 and wifi calling notifications

Elytherial
Member

ever since the latest security update, on or around June 20,2018, i have been getting notifications to set up wifi calling. So i do...all the steps...

and it STILL sends the same notification.  So i turn off wifi calling, and the notifications continue. Is there a way i can disable that annoying notification covering my screen periodically?

Labels (1)
1 Solution

Correct Answers

Re: s8 and wifi calling notifications

Community Manager
Community Manager

Elytherial & Teevo42, I wouldn't want to see a notification like that continually appearing myself. The latest update for the S8 did include a notification for Wi-Fi Calling, asking to make sure you an Emergency Address entered. This address is needed for 911 calls. To make that go away, you do want to make sure to add the address: http://spr.ly/6581DmK2U

Samsung has the steps for setting up Wi-Fi Calling outlined here: http://spr.ly/6584DmK2s

If that's not the notification you're seeing, please share what specific notification you are getting.

John_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

View solution in original post

0 Likes

Re: s8 and wifi calling notifications

Teevo42
Member

I also want this to go away. Can't find anything that disables the notification. Never happened prior to the system update I installed this morning. Hoping someone from Verizon responds.

Re: s8 and wifi calling notifications

BNANK
Member

I have the exact same NAG after my phone updated this morning!   I have been searching for over an hour on how to make it go away with no success!

Pretty bad we pay an outrageous fee for a service then they try to force us to use WIFI and not the service we pay for!  Do we get a discount for using wifi calling?  ROFL!

Verizon make this nag go away!

0 Likes

Re: s8 and wifi calling notifications

natcatcat
Member

I FINALLY got rid of it!

Step 1: attempt to swipe it away

Step 2: click the settings cog button that appears

Step 3: press the various options until you find the one that disables it (sorry I forget which one and I don't want to bring it back to find out)

Hope this helps the rest of you!

Re: s8 and wifi calling notifications

nspitz
Member

So I think I fixed it. I had the same problem after the update. I think the root cause is that the app "advanced calling" doesn't have permission to access phone calls.

To fix, go to settings - connections - advanced calling. A pop up should ask you if you want to give advanced calling the permission. I enabled wifi calling from there and am no longer receiving the notifications. Tested after disconnecting and reconnecting as well as a restart. If the pop up doesn't appear, go to settings - apps. Then click show system apps from the top right menu. Then go to advanced calling - permissions and enable phone permissions.

Re: s8 and wifi calling notifications

ssxlv
Member

Nailed it! Thanks natcatcat!!!

Re: s8 and wifi calling notifications

Community Manager
Community Manager

Elytherial & Teevo42, I wouldn't want to see a notification like that continually appearing myself. The latest update for the S8 did include a notification for Wi-Fi Calling, asking to make sure you an Emergency Address entered. This address is needed for 911 calls. To make that go away, you do want to make sure to add the address: http://spr.ly/6581DmK2U

Samsung has the steps for setting up Wi-Fi Calling outlined here: http://spr.ly/6584DmK2s

If that's not the notification you're seeing, please share what specific notification you are getting.

John_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

View solution in original post

0 Likes

Re: s8 and wifi calling notifications

Teevo42
Member

John, the link you provided does not actually describe how to add this "required emergency address" as you mentioned being the fix. Atleast nothing that I saw on that link.

And what if we don't want to provide that info? I don't see how Verizon can force people to setup and give personal info if they don't want to. I don't foresee myself ever using wi-fi calling. It should not be auto-on, in my opinion. Everything should have an option to be on or off.

Is there no other way to remove this notification? If no, can you please provide a step by step on how to do this since your link did not? Thank you.

Re: s8 and wifi calling notifications

Teevo42
Member

@natcat - I tried that, but none of the options permanently disables it. Only temporary. I tried all the "importance" options: urgent, high, medium, low. None took it away permanently :/

0 Likes

Re: s8 and wifi calling notifications

Teevo42
Member

@nspitz - unfortunately this didn't help either, I checked what you said and mine was already enabled  :/

0 Likes