Highlighted

Why can't I send MMS when connected to wi-fi?

Member

I am unable to send MMS when connected to wifi.  I have data on and can see that I am connected to both a wi-fi and VZW data connection; however, cannot send MMS messages.  I can receive them fine, but not send until I turn wifi off which I should not have to do just to send an MMS.  This occurs both on my wife and I's S IIIs.  Is there a setting I am overlooking a setting on our phones because I should not have to switch wifi off every time we send an MMS?

Labels (1)
Tags (1)
0 Likes
1 Solution

Correct Answers
Highlighted

Re: Unable to send MMS when connected to Wifi

Sr. Leader

This thread is in response to the issue on an S4, but should still be helpful:

There are similar threads on this forum if you want to do a search.

View solution in original post

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Sr. Leader

This thread is in response to the issue on an S4, but should still be helpful:

There are similar threads on this forum if you want to do a search.

View solution in original post

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Member

I have search different threads, but none of them either worked for me or do not provide a clear answer.

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Member

I am also unable to send pictures over Wifi. Samsung Galaxy S3.

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Sr. Leader

Rogena wrote:

I am also unable to send pictures over Wifi. Samsung Galaxy S3.

The phone is operating as designed; MMS messages can't send/receive over wi-fi, they require a cellular connection.  They count against your text package, though, not your data plan.

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Member

Got it! I had turned off mobile data trying to make sure data wasn't used while on Wifi. Should not have done that since the phone does it automatically. 😃 Thank you.

Highlighted

Re: Unable to send MMS when connected to Wifi

Sr. Leader

Yes, if you have cellular data and wi-fi both turned on and you are currently using wi-fi, the phone should switch automatically to cellular data.  But as noted in this and other threads, sometimes it doesn't automatically switch and you have to manually turn off wi-fi for the messages to send/receive.  In your case, having cellular data turned off was an issue!   I also leave cellular data turned off until needed, like when a MMS arrives.

Highlighted

Re: Unable to send MMS when connected to Wifi

Member

I turned it off when I realized both Wifi, and 4G was showing in the top bar. I was afraid it was using data at all times. I think I will do like you and turn it back on as needed. 😃

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Member

You should not have to switch wifi off to send an mms. The phone allows me to receive an mms while connected to both wifi and 4G and can auto switch to the 4G connection for the reception of the message.  Why can it not do the same for receiving?

0 Likes
Highlighted

Re: Unable to send MMS when connected to Wifi

Sr. Leader

I don't know; it's been an issue reported on this forum for both the S3 and S4 for a while.  I've heard it may be that the wi-fi signal is stronger than the cellular signal and that may be the cause, but again, I don't know.  You're right, the phone should switch, but for whatever reason, it sometimes doesn't.

0 Likes