Accessibility Resource Center Skip to main content
Get it fast with In-store & curbside pickup or same day delivery.

Update Not Working

Grither
Member

So I have tried everything to get the 4.3 update to work on my Galaxy S4. I even factory reset the entire phone, deleting absolutely everything, and the update STILL doesn't work. It takes forever to download, then it verifies the download, then it starts the installation. Then after a minute or two of "installing" the little android icon falls over with a red triangle above his belly and it says "Error." Then the phone restarts, and it says "Update unsuccessful: There was an issue installing the update, and your phone has not been updated" or something. How do I fix this??

And to add insult to injury, now I can't even use the google play store to download the My Backup Pro app to restore all my data from my SD card! I'm about ready to throw the damn thing out the window. (But this is probably just due to Verizon coverage being awful and slow in NYC, which is why I wanted to update in the first place, as I'm told it's supposed to open up a new LTE band to hopefully makes things less miserably slow!)

Labels (1)
0 Likes

Re: Update Not Working

vzw_customer_support
Customer Support

Not so fast with throwing the phone, Grither! Sounds like you have done lots of troubleshooting. Let me handle it from here. I just sent you a follow request. Please follow me back and send a private message with your mobile number and password along with your full name.

Thank you,

LenaA_VZW
Follow us on Twitter @VZWSupport

0 Likes