Roaming

Member

Apparently there is no way to defeat voice roaming on this phone. When I get near Mexico which I do 3 or 4 times a month I have to turn the phone off or the more powerful Mexican network hijacks it. At that point any call I make is "international" and billed to me at 1 dollar a minute. I know how to turn off data roaming but from what I have learned this phone was sent out to customers with no way to prevent this kind of hijacking. Anyone have any ideas about how to fix this?

I had no problems with my other phones, just this one. Verizon recommended this phone to me as a replacement for my Droid RAZR MAX which had a defective USB port which, of course, Verizon refused to repair. So, if you don't like having your phone hijacked, stay away from this puppy.

Rgrds-Ross

Labels (1)
Tags (1)
0 Likes
Highlighted

Re: Roaming

Member

If you enable Roaming alert in Sounds, u will be notified when your picking up roaming towers and just don't use it at that point.  Pretty simple, maybe u can find an app that will disable voice roaming which would mean you wouldn't be able to use your phone anyway if it picked up on a roaming tower.

How far are you from the border? 

0 Likes
Highlighted

Re: Roaming

Member

About three miles. I'll try the notification trick, it's better than nothing. What's frustrating is that Verizon does have a tower, the Mexican tower is just stronger so the phone "prefers it" and switches to GSM and there we go with one dollar a minute. I end up there about 3 or 4 times a month. I may just get a non smart phone that can have the feature switched off but I distinctly remember that my old phone didn't evince this behavior.

Rgrds-Ross

0 Likes
Highlighted

Re: Roaming

Expert

Would it be cheaper to add a Mexico calling plan feature to your account to cover an roaming charges?

I do wonder if you call customer service and have them block any international roaming on your line.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Highlighted

Re: Roaming

Member

Do you have the phone set to Global? U  might try setting it to cdma home?  Let me find that app that gives you more network options , its called

0 Likes
Highlighted

Re: Roaming

Member
0 Likes
Highlighted

Re: Roaming

Community Manager
Community Manager

Hi rsalinger,

I understand your predicament! Please ensure that global data is not enabled. Go to settings>more networks>mobile networks>network mode>select LTE/CDMA and test on your next trip to the border. Keep us posted.

AntonioC_VZW
Follow us on Twitter at www.twitter.com/VZWSupport

0 Likes
Covid19