Highlighted

Galaxy s3/NETGEAR Router Wifi Problem and Solution

Member

I was having a problem and found a fix.  I am sharing it with you FYI. 

I have two Galaxy s3 phones.  I could not get them to connect to my home wifi.  I have a NETGEAR model WNR1000v2router.  The default security option is:
"WPA-PSK(TKIP)+WPA2-PSK(AES)".

The phones would see the SSID and request the password.  Access would fail and the phones would prompt me to enter the passcode again.  By changing the security option to:
"WPA2-PSK(AES)"

the phones can now connect to my home wifi. 

Labels (1)
0 Likes
Highlighted

Galaxy s3/NETGEAR Router Wifi Problem and Solution

Expert

Do you have MAC address filtering turn on in the router?

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Highlighted

Re: Galaxy s3/NETGEAR Router Wifi Problem and Solution

Member

Nope. I checked that first.

0 Likes