Highlighted

Galaxy S4 using mobile data despite being connected to home wifi network.

Valeriu6853
Member

How can I make the home wifi connection take priority?

Labels (1)
0 Likes
1 Solution

Correct Answers

Re: Galaxy S4 using mobile data despite being connected to home wifi network.

BigRedGonzo
Novice

Valerius,

Just a shot in the dark, but the S4 has a "feature" that monitors WiFi connection quality and automatically switches back to Carrier Data if the WiFi signal begins to degrade.  My son and I did a test and found that while standing in the room with the router (at the house) we both got full bars on the WiFi signal and the WiFi held.  We then moved to the other end of the house and the WiFi signal dropped by one bar.  The phone, shortly thereafter, switched to Carrier Data because the WiFi connection degraded.  The solution to the problem was to go to Settings>WiFi>Menu>Advanced and unchecked the AutoSwitch option.  The phone now stays on the house WiFi until out of range.

I don't know if that is what your issue is, but its worth looking into.

BigRedGonzo

View solution in original post

0 Likes

Re: Galaxy S4 using mobile data despite being connected to home wifi network.

Community Manager
Community Manager

Its great that you're using WiFi when possible to avoid high data usage/ charges Valeriu6853! You can actually turn off Mobile Data altogether. This will allow you to only use WiFi. To do so, you can go to Settings>More Settings> Mobile Networks> uncheck Mobile Data.

Thank you,
VanessaS_VZW

Follow us on Twitter @VZWSupport

0 Likes

Re: Galaxy S4 using mobile data despite being connected to home wifi network.

BigRedGonzo
Novice

Valerius,

Just a shot in the dark, but the S4 has a "feature" that monitors WiFi connection quality and automatically switches back to Carrier Data if the WiFi signal begins to degrade.  My son and I did a test and found that while standing in the room with the router (at the house) we both got full bars on the WiFi signal and the WiFi held.  We then moved to the other end of the house and the WiFi signal dropped by one bar.  The phone, shortly thereafter, switched to Carrier Data because the WiFi connection degraded.  The solution to the problem was to go to Settings>WiFi>Menu>Advanced and unchecked the AutoSwitch option.  The phone now stays on the house WiFi until out of range.

I don't know if that is what your issue is, but its worth looking into.

BigRedGonzo

View solution in original post

0 Likes