Highlighted

Galaxy S4 mic audio dropping/silent during calls

joejarvis
Member

Hi all. I could use some help diagnosing a call audio problem with the Samsung Galaxy S4. I've done a lot of testing and am running out of ideas.

PROBLEM

During calls in my apartment, call recipients frequently report that my audio will drop out/go silent for 1-10 seconds, then return. This can happen multiple times in a call. At its worst, calls will drop, but this is extremely rare. Based on my troubleshooting, it appears to be a systemic defect in either the Galaxy S4 hardware or software.

TROUBLESHOOTING TO DATE

Network. Verizon claims its network is functioning correctly near my apartment. They have sent a crew to the site to verify and see no problems. This is a relatively newly developed suburban area inside a city with ~90K population.

To rule out network problems, I bought a Verizon network extender. It's configured for closed/managed access. The phone display indicates it is connected to the network extender, dialing #48 verifies network extender coverage, and Verizon techs can verify from their call logs that calls are being placed through the network extender. Verizon can also tell based on the tower ID in their logs that I'm using the same tower consistently, which I interpret to rule out accidentally connecting to a network extender in a neighboring apartment.

To verify the connection between the phone and the network extender, I started using the OpenSignal app on the phone to monitor the signal strength. I'm averaging low -70s dBm, with lows in the -50s dBm and highs in the -80s dBm. I've monitored the signal strength during calls, and when the problem occurs the signal is consistent with these numbers. I've relocated the network extender to be as close to where I place calls as possible, and am typically 5-15 ft away with an interior sheetrock wall between me and the network extender.

Since the network extender routes calls over the Internet, I've also tried to rule out both my home network and my broadband ISP as the source of the problem. I've replaced the Ethernet cable between the network extender and my router. My cable broadband provider advertises 2 Mbps upstream bandwidth on my current plan. Speedtest.net bandwidth tests to various servers show that I regularly get 1.2 - 1.8 Mbps in practice, including near the times when I have problems. I already had quality-of-service configured on my router and configured it to prioritize outbound packets from the network extender based on its MAC address. Only DNS, NTP, SSH, and packets bound for my ISP's WAN get higher priority.

During calls I can watch graphs of the router's outbound bandwidth on the router's private administration website. Outbound calls are using 6 Kbps per line. When the problem occurs, there is no drop in the outbound bandwidth from the router, and no other inbound or outbound traffic is happening. Pings to the remote IP address of the server the network extender uses seem to average about 40-50 ms, but I think I've seen them as high as 100-110 ms a few times. The path between my router and the network extender server IP is about 15-20 hops. Based on reverse DNS it appears to transit from me (Kansas) to Atlanta to New York to Dallas to Verizon (location unknown).

Device. To rule out a faulty device, I had Verizon replace it with an identical certified used Galaxy S4. The problem occurs on the replacement phone too. To help isolate the problem on the phone, I bought a Bluetooth earbud. I also have a Bluetooth handsfree system in my car. The problem has never occurred using either Bluetooth device. I've verified that noise cancellation and sound personalization are both turned off during calls. The problem also occurs when running in safe mode, which disables non-Verizon apps.

Location. I make 95% of my calls from my apartment. I seem to recall having the problem standing in the parking lot outside my apartment a couple times, but don't really remember the problem occurring anywhere else that's away from my apartment. My sample size isn't very large for calls away from home. As for possible sources of interference, I've got a microwave, a dual-band 802.11n WiFi router, and my spouse has a Verizon HTC Droid Incredible 2. Since it's an apartment building, I'm near many other people, and I don't know what they're doing in their units. My spouse with the HTC phone, which is now also routing over the network extender, has never had the problems I'm having. I upgraded to the Galaxy S4 from an HTC Thunderbolt and didn't have problems before upgrading either. The lack of problems with two different HTC devices in this location and the verified signal between the Galaxy S4 and the network extender make me think a location-specific problem is unlikely. I also haven't heard any complaints from neighbors about cell phones not working locally.

NEXT STEPS

I'm running out of things to test. I've worked with several Verizon techs on the issue and seem to have exhausted their toolkit/knowledgebase. It seems like it's either a systemic hardware or software defect in the Galaxy S4 design. What else should/could I check? I work from home and rely on the phone, so I've invested a lot of time and money to try to solve this. All help appreciated!

Labels (1)
0 Likes

Re: Galaxy S4 mic audio dropping/silent during calls

joejarvis
Member

Bump. VZW are you out there?

0 Likes

Re: Galaxy S4 mic audio dropping/silent during calls

lancem
Member

I've experienced the exact same problem!  I too had my Galaxy S4 replaced.  The replacement is much better but still occasionally causes me to be muted to the person I'm speaking too.  The problem has never occurred while on bluetooth or on speaker phone...only while holding the phone against my face.  The screen turns off normally and it is definitely not a case of me accidentally pressing the mute button, although the effect is almost as if I pressed the mute button.  Sometimes the other person can hear me very faintly.  The consistent way that I "fix" it is to pull the phone away from my face for a second and then back and the other person immediately hears me normally.  Check if this "fix" works for you too?  There is definitely something wrong with the phone.  For me it's not severe enough to want to deal with moving over to a new phone at this time.

0 Likes