4g LTE messed up

Amarithmoon
Member

I have had my S3 for several months.  I have not moved.  I have always had decent 4g at home.  Very seldom will it drop to 3g.  However, all day yesterday and most of today I have been on 3g with network type of eHRPD:13 instead of LTE: 14.  I went to my local corp store, and asked if they were doing something with any of the towers in the Moline area.  Was told that all towers were at 4g and have not had anything done to them in months.  I explained I have had my phone for several months and no issue, until yesterday.  Asked if I had 4g anywhere else.  Yes, in fact I did in the store.  However, now I have no 4g at home at all.  Im very frustrated.  I know the sim I was issued came out of a bad batch.  I watched them throw away literally 6+ sims from the bag they came in, until one let the phone activate.  I wont say my 4g has been excellent, but it was at least working until yesterday.  Any ideas?

Labels (1)
Tags (3)
0 Likes
Highlighted

Re: 4g LTE messed up

Community Manager
Community Manager

Hey there Amarithmoon. I am jealous to see that you have the S3. It is a great device and I am thinking about getting one myself when I am upgrade eligible. I like that the screen is big, but not huge so it doesn't fit in my pocket. The perfect size for me. I am sorry to hear that you are having connecting to our 4G network. While 3G is fast, 4G LTE is much faster and once you experience it, its hard to move backwards. Lets take a closer look to see if we can speed things up.

Are you still having issues connecting to 4G? I don't believe its an issue with the SIM card since you are recieving a 3G data connection. If it was a sim card issue you wouldn't receive any data at all.

Could you try powering the device off and removing the sim card. Leave it out for about 30 seconds. Go ahead and put the sim card back in and power the device back on. Once the device is back on let me know if you have a 4G connection.

Also I want you to go to Network Mode through settings to make sure that you have LTE/CDMA selected and that system select is set to automatic. To view the steps on how to get there please visit http://vz.to/15btKLW.

Keep us updated with your results and let us know if you need additional assistance.

NickB_VZW
VZW Support
Follow us on Twitter @VZWSupport

0 Likes
Highlighted

Re: 4g LTE messed up

techman05usa
Member

Check if your network is set to global. When I updated to 4.1.1 on my new phone it defaulted to global and roaming. I had to select the default wireless back to lte. Try that and you should be golden.