Highlighted

4G Lit even when on Wifi

StevieD2
Member

I recently upgraded my S8 to Android Pie. Since then, when I am on Wifi, the 4G icon is lit up. In the past, when I was on wifi, it was greyed out. When I use device maintenance to close all background apps, it goes off temporarily, but comes back on in a few seconds to a few minutes. I tried closing individual background apps and have concluded that Verizon Messages +, my texting app, is what is causing this. In fact, when I open the app and close it, the 4G immediately goes off temporarily.

I don't know if this is a problem or if Verizon even knows about it. Is it using data while I am on wifi? Does anyone else have the same issue?

0 Likes

Re: 4G Lit even when on Wifi

bearone21
Leader

you're not using wi-fi, flips to network if wi-fi is weak.

0 Likes

Re: 4G Lit even when on Wifi

StevieD2
Member

@bearone21 wrote:

you're not using wi-fi, flips to network if wi-fi is weak.



Not sure what you are trying to say. l am absoultely using Wifi and the 4G is lighting up, when it did not do this on Oreo. My setting for "switch to mobile data" if wifi is unstable is set to OFF. Finally, it seems to be one app causing this...Messages +.

 

Are there any Verizon engineers who can address this?

0 Likes

Re: 4G Lit even when on Wifi

Klue
Sr. Member

1. Does this happen with all Wifi networks?

2. Have you tried using another messaging app to verify if its is truely messages+?

3. Have you turned off data to see if the 4g light will stay off? just to verify if the light is defective.

Re: 4G Lit even when on Wifi

StevieD2
Member

@Klue wrote:

1. Does this happen with all Wifi networks?

2. Have you tried using another messaging app to verify if its is truely messages+?

3. Have you turned off data to see if the 4g light will stay off? just to verify if the light is defective.


1) not sure about other networks...will check when I am at another location

2) I would have to disable messages+, as the light comes on even when app is closed. Something is launching automatically in the background. But when i close messages+, the light immediately goes off temporarily.

3) This was a great idea...I turned mobile data off and the light immeditely went off, so the light is not devective. Interestingly enough, since I turned data back on, the light has not come back for about a half hour. It is possible this fixed the issue, though I would need to wait a few days to be sure. Will keep you posted.

 

Thanks!

0 Likes

Re: 4G Lit even when on Wifi

Klue
Sr. Member

If you find out that 4g does not activate when on other wifi networks, then make sure your home router has the latest software update and reboot it. This really sounds like your home wifi is not strong enough and the phone is using data to help out even though you have that turned off.

0 Likes

Re: 4G Lit even when on Wifi

Community Manager
Community Manager

StevieD2, I can certainly understand your concerns with the 4G indicator on your phone despite being connected to Wi-Fi. Help is here. Do you have the same experience with other smartphones on the same Wi-Fi network? Since you suspect that Verizon Messages may be the culprit, are you able to delete the Verizon Messages app on your phone, and let us know if that resolves your 4G indicator issue? Please keep us posted with the results.

 

LorenzoP_VZW

0 Likes

Re: 4G Lit even when on Wifi

StevieD2
Member

@Klue wrote:

If you find out that 4g does not activate when on other wifi networks, then make sure your home router has the latest software update and reboot it. This really sounds like your home wifi is not strong enough and the phone is using data to help out even though you have that turned off.


Thanks, but I don't think my router is an issue at all. I get a consistent throughput of 300 Mbps on my phone on my wifi at home. In addition, I never had this issue until I upgrded to Android Pie a few days ago. Also, I have Switch to Mobile Data OFF. Finally, the light is still off since my last comment.

0 Likes

Re: 4G Lit even when on Wifi

StevieD2
Member

@vzw_customer_support wrote:

StevieD2, I can certainly understand your concerns with the 4G indicator on your phone despite being connected to Wi-Fi. Help is here. Do you have the same experience with other smartphones on the same Wi-Fi network? Since you suspect that Verizon Messages may be the culprit, are you able to delete the Verizon Messages app on your phone, and let us know if that resolves your 4G indicator issue? Please keep us posted with the results.

 

LorenzoP_VZW


Other phones on the network are iPhones and don't have this issue.

Seems like an extremely radical solution to delete the app that I have used for almost 2 years, which is your own app. I expect a higher level of tech support before taking such a radical step.

0 Likes

Re: 4G Lit even when on Wifi

Klue
Sr. Member

Here is something I just noticed. My wife and I have identical S7's, running on Oreo, (we don't get the Pie) set up the same way. When both are connected to home wifi my 4G indicator is grayed out and her 4G indicator is lit all the time. Even though it is lit the upload/download arrows underneigh the 4G light are not activating, so no data is being used. Sort of odd that two S7's setup the same way will show different on the 4G indicator lights.

0 Likes