Highlighted

How to accept "Private caller" phone calls?

Member

I was expecting a call from a State Patrol officer this evening and he tried to call 4 times - but my phone never rang.    Instead it just shows "Private Number" on the screen and automatically blocks his calls.    I searched through settings and see nothing to "Allow Private number" calls.

 

I tried switching to the "Dialer" app and it has the same problem - no way to accept a "Private Number" call.   I did find a setting for "Reject Anonymous calls" - and turned that off, but it makes no difference.   I tried calling my own phone after blocking the phone number and my stupid Note 8 will not let the call go through.

Does anyone know how to accept "Private number" calls?   

0 Likes
Highlighted

Re: How to accept "Private caller" phone calls?

Member

I was able to contact Verizon support and now I can accept "Private Number" phone calls.

The solution was to go to the first screen of the dialer and select "Blocked numbers", and then turn off "Block Anonymous calls" (slide the On/Off to the "Off" position).    

I had done this myself, but it did not change anything and it still automatically rejected any blocked call.   So Verizon support suggested to "Reset Network Adaptor".    After doing this, it now will accept blocked phone calls (Such as the State Patrolman who must have his number blocked for security reasons).    I am using the "Dialer" app with the blue oval icon.

0 Likes
Highlighted

Re: How to accept "Private caller" phone calls?

Member

Unfortunately, this "Fix" only lasted a few hours, and when the State Patrol officer called, then it went back to rejecting any "Private" phone calls.

SUPER FRUSTRATING

 

0 Likes