My Verizon App Not Working on iPhone 7

Member

I got an iPhone 7 earlier this year and the My Verizon app has never worked. It worked perfectly on my iPhone 6, but not since i got the 7.  When I open the app it says "Our system is unavailable at the moment."  and when i click the retry button at the bottom it says "Unable to process your request at this time.  Please contact Customer Service by dialing *611."

If I access My Verizon online, my data usage and everything comes up just fine, but i need to be able to view it on my app since i monitor it all the time to make sure i'm not using too much data....

So I have contacted customer service through online chat and by phone multiple times.  Uninstalled the app, reinstalled the app, restarted my phone, or a combination of the previous three things several times.  Nothing has worked and Verizon finally said that it must be due to the fact that i'm on a business account (my phone is paid for by work) and they must have a restriction on my phone for that app or its capabilities.

I asked our company Verizon person and she said we had no such restriction and the plan is exactly the same as what i had on my iPhone 6 (which was also under the company plan) so nothing should be affecting the app.

So please if anybody has any thoughts or solutions, I need your help!!

Labels (1)
0 Likes

Re: My Verizon App Not Working on iPhone 7

Customer Support

skendri, We're sorry to that you're having trouble with the Verizon application. We appreciate all your efforts in trying to get this resolved. We are working towards a resolution. Please send us a log of the issue by completing the followign. Go to phone settings, privacy, diagnostic and usage, Select Automatically send and turn the option "Share with App developer's ON and send the screenshot.

 

TrinetteW_VZW

Follow us on Twitter @VZWSupport

If my response answered your question please click the �Correct Answer� button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes