Highlighted

Why won't my device connect to wi-fi?

Member

My Droid Turbo 2 will not connect to the wireless router at my work place.  I have a Cisco Dual Broadband wireless N router at home with WPA2 security that the phone will connect to with no problems. At work it is a linksys single broadband 2.4ghz router. When I attempt to connect to the linksys, it says "Connecting" briefly then goes right back to saved. After 3 attempts it says "Wi-Fi Connection Failure" but will not elaborate. We have tried rebooting both the phone as well as the router. I tried with the "Avoid Bad Wi-Fi Connections" both on and off. We tried changing the security on the router to accept both WPA and WPA2 PSK security types. We tried connecting to the router via different channels. I tried connecting with the 2.4ghz only option. We tried to manually enter the SSID and security/DNS settings. It still will not connect. A fellow employee has a Droid Moto X through republic wireless, which as well has Android 5.1.1. He has no issues connecting to the Wi-Fi with the same settings I am attempting to use. I can as well connect to the a different router in my work place ( I have no details on type) that is generally out of range.

Any ideas?

Labels (1)
Tags (1)
1 Solution

Correct Answers
Highlighted

Re: Cannot get my Turbo 2 to connect to wifi...

Member

Go into wifi under settings and then Advanced (upper right hand corner)  and unselect avoid bad wifi connections and then select 2.4 GHZ from the wifi frequency band.  Also make sure Airplane mode is turned off.   This seems to work out well for some phones.

View solution in original post

0 Likes
Highlighted

Re: Cannot get my Turbo 2 to connect to wifi...

Member

Go into wifi under settings and then Advanced (upper right hand corner)  and unselect avoid bad wifi connections and then select 2.4 GHZ from the wifi frequency band.  Also make sure Airplane mode is turned off.   This seems to work out well for some phones.

View solution in original post

0 Likes
Highlighted

Re: Cannot get my Turbo 2 to connect to wifi...

Member

I am having the same problem. I just got this phone on 11/27/2015 and can login to my WIFI at home. My work wifi pops up and says connected. However My work, we have to enter a guest email and the screen doesn't come up, I have a big red padlock. I checked the 3 dots to the upper right My only option is Don not use this network and Use this network as is. When I click use as is, nothing happens. I had a Galaxy S3 before and it worked perfectly fine with wifi.  This seems to be a problem with this phone. Please help.

0 Likes