Highlighted

Razr Maxx Not working in Vietnam

Member

I have the international plan added.

Under settings>mobile network settings>Network mode, I have selected Global

Under settings>global data roaming access, I have selected allow access for all trips

I have turned the phone off and back on, and reset it.

I used the chat feature, but they said I needed to call customer support.

I called customer support, and like every terrible troubleshooting list has, they had me turn off the phone and turn it back on, which of course wasted 5 minutes of my time.  Then they said I needed to put +84 in front of the numbers, which is also useless since it's not connecting. 

They transferred me to tech support, who then listened to my problem and put me on hold until my prepay minutes ran out even though I told them I had a prepaid phone and therefore didn't have a lot of time to sit on hold.

Has anyone done anything other than the above in order to get their phone to connect internationally?

Labels (1)
0 Likes