Highlighted

Question mark in battery symbol

buckchaser
Member

The other day I did some app updates and restarted my phone. After startup, a question mark showed up in the battery icon. The phone was working fine otherwise though. I power cycled it a few times and the question mark would not go away. Apparently it would not charge either, as it is now DEAD. When I plug the phone in, I just get the battery icon with the question mark symbol. I took it to a local Verizon store (2 in fact) and they were of no help. I have only had the phone for just over a year (so no warranty or insurance), and I love it. There is no way I'm paying for a brand new phone when I did absolutely nothing to damage it! After doing some research I have noticed that other people have had this problem as well. I cannot even call customer service because I am alone without a phone!

Labels (1)
0 Likes
1 Solution

Correct Answers

Re: Question mark in battery symbol

Ann154
Expert

Contact Motorola and see if they will replace the battery for a fee. Since you will have to send the phone in, you should see if you can borrow a phone from a friend in the meantime.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

View solution in original post

0 Likes

Re: Question mark in battery symbol

Ann154
Expert

Contact Motorola and see if they will replace the battery for a fee. Since you will have to send the phone in, you should see if you can borrow a phone from a friend in the meantime.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

View solution in original post

0 Likes