Bluetooth Audio streaming drops connection after 2.2 upgrade

justobuff
Member

I have had the Motorola Droid since November 2009 and have been streaming audio since then to my car.  I believe my car uses BT 2.0 standard. I use mostly Pandora and Slacker.  After receiving the Froyo 2.2 update FRG22D I have had consistant problems with the Bluetooth Connection dropping.  The connection will drop and I will have to manually go to the wireless settings and click the device to reconnect it.  The drop occurs persitantly.  It will occur anywhere from a few seconds to 15 minutes after being connected.  On a 30 minute car ride I am lucky if I only have to reconnect once.  This as you may guess is not safe to do while driving.  I have had this problem now for about 3-4 weeks.  I have seen a few posts on other sites with the same issue, but no solutions.  I have tried reseting the bluetooth pairing and soft reseting ( took battery out for 5 minutes).  If a firm reset will fix I will do it, but hate to do it if it won't fix it. 

0 Likes
Highlighted

Re: Bluetooth Audio streaming drops connection after 2.2 upgrade

bmurr22
Member

I had the same problem as you using Ford's Sync system, but I found I was able to resolve the problem by turning off the wifi because of the bug that tries to join networks it sees and then fails over and over again.  I have had nothing but issues with wifi enabled since the 2.2 update.

0 Likes
Highlighted

Re: Bluetooth Audio streaming drops connection after 2.2 upgrade

Tomakron
Member

Thank you, thank you, thank you.  I have been going nuts with the skips, drops and partial songs listening to Pandora with Bluetooth since the upgrade.

 

I use the Ford Sync System and the Motorola Stereo Bluetooth headset and constantly get the drops and skips.

 

Just went out to lunch and connected through Sync with WiFi searching and immediately got the skips and drops.  Shut off WiFi search and all worked fine --- NO DROPS or SKIPS.   I turned the WiFi back on and Drops and Skips returned immediately.

 

Tried this about 4 times with same result. 

 

Fix should be easy for the techies --- Just put in an "X" punch or and "If" statement and all is well.

 

Thanks again.

0 Likes