Disabling the Apple iPhone native messaging app

NetWorker
Member

I am having trouble disabling the Apple iPhone native messaging app.  I have gone into settings > Messages and switched off iMessage and MMS messaging. I still receive messages in both the Verizon Messages app and the native messaging app.  Is there something else I need to do? 

iPhone 5s, iOS version 9.2.1

Labels (1)
0 Likes
1 Solution

Correct Answers
Highlighted

Re: Disabling the Apple iPhone native messaging app

rcschnoor
Sr. Leader

NetWorker wrote:

I am having trouble disabling the Apple iPhone native messaging app.  I have gone into settings > Messages and switched off iMessage and MMS messaging. I still receive messages in both the Verizon Messages app and the native messaging app.  Is there something else I need to do? 

iPhone 5s, iOS version 9.2.1

There is no "native" way to keep the iMessage app from receiving SMS/MMS messages which are sent to your cellular number if you STILL want to receive those same messages on the Verizon Messages app on the same phone. Those messages will still display on your device within iMessage. What you CAN do is to disable notifications for that app. Then you won't get notifications from both apps installed on your phone. Simply have the notifications only turned on for one of the apps, the one you wish to use.

Keep in mind, for whatever reason OCCASIONALLY I will not receive a text on my Verizon Messages app and when asked about it by the sender I will go into the iMessage app and it will be sitting there waiting to be read. It doesn't happen very often, but it does happen.

Finally, the way you can tell the difference between iMessages and SMS/MMS from within the iMessage app is that iMessages will have a blue bubble around them and SMS/MMS messages will have a green bubble around them.Smiley Happy

View solution in original post

Re: Disabling the Apple iPhone native messaging app

kaebfly
Leader

Are the messages you're receiving iMessages? If so they won't go through Message+ and will only show on the iPhone app. You can opt to turn off iMessages so that everything you receive comes as a sms message.

0 Likes

Re: Disabling the Apple iPhone native messaging app

NetWorker
Member

kaebfly

Thanks for the response.  I don't think they are iMessages, though I wouldn't know how to identify an iMessage if I fell in a pile of it.  Most of these messages come from another user of Verizon Messages using a droid, so I don't think they are iMessages.  In fact, EVERY message that I receive appears in both apps - Verizon Message and the native message app.

As I said, I have gone into settings > Messages and switched off iMessage and MMS messaging.  Other than that what do I need to do to turn off iMessages.?

0 Likes

Re: Disabling the Apple iPhone native messaging app

kaebfly
Leader

Sorry I didn't notice you said you had turned it off. It's possible you need to look at a setting in Message+. I don't use it since the iPhone messaging app works perfectly fine for me. Perhaps someone that uses it will chime in.

0 Likes

Re: Disabling the Apple iPhone native messaging app

Tidbits
Sr. Leader

There's no way to turn off Apple native features.

0 Likes

Re: Disabling the Apple iPhone native messaging app

NetWorker
Member

Tidbits

There is always a way.  It may not be a way that is supported by Apple, but there is always a way.....

0 Likes

Re: Disabling the Apple iPhone native messaging app

kaebfly
Leader

Those ways you won't be advised of on here but if you're aware of them and are willing to do it then you appear to have answered your own question. Officially and legitimately there seems to be no way to turn off Apple native apps if settings does not allow it. Doesn't appear to be an option to turn it off in restrictions either. Couldn't find anything on Apple's Support site either.

0 Likes

Re: Disabling the Apple iPhone native messaging app

JohnnyDoe
Novice

Networker -

If you don't mind me asking, what problems are you having with the native Apple Messaging app? I've been having ongoing MMS - both group / picture messaging for months now and between Apple / Verizon they can't seem to get it figured out. But the Verizon Messages+ app works fine for me (just sucks cause I have to use two apps for messaging). Just curious what issues you are having though.

0 Likes
Highlighted

Re: Disabling the Apple iPhone native messaging app

rcschnoor
Sr. Leader

NetWorker wrote:

I am having trouble disabling the Apple iPhone native messaging app.  I have gone into settings > Messages and switched off iMessage and MMS messaging. I still receive messages in both the Verizon Messages app and the native messaging app.  Is there something else I need to do? 

iPhone 5s, iOS version 9.2.1

There is no "native" way to keep the iMessage app from receiving SMS/MMS messages which are sent to your cellular number if you STILL want to receive those same messages on the Verizon Messages app on the same phone. Those messages will still display on your device within iMessage. What you CAN do is to disable notifications for that app. Then you won't get notifications from both apps installed on your phone. Simply have the notifications only turned on for one of the apps, the one you wish to use.

Keep in mind, for whatever reason OCCASIONALLY I will not receive a text on my Verizon Messages app and when asked about it by the sender I will go into the iMessage app and it will be sitting there waiting to be read. It doesn't happen very often, but it does happen.

Finally, the way you can tell the difference between iMessages and SMS/MMS from within the iMessage app is that iMessages will have a blue bubble around them and SMS/MMS messages will have a green bubble around them.Smiley Happy

View solution in original post

Re: Disabling the Apple iPhone native messaging app

NetWorker
Member

If it can't be turned off, what is the purpose of the iMessage on/off switch in Settings > Messages? Also, if I may ask a bit of an off-topic question, does the iMessage app use the iMessage infrastructure when communicating with another apple device and SMS/MMS when communicating with a non-apple device?

Perhaps I just answered my own question.  Maybe turning off iMessage forces everything to be sent as SMS/MMS?

0 Likes