Highlighted

Trouble mounting my microSD card despite hours of troubleshooting.

I'm rather tech savvy and very intelligent. Just wanted to get this out of the way before I go on. I purchased my phone about three or four days ago. At first, I was in love...and that grew daily. Now, I was able to mount my microSD card twice with, literally, no issues at all. However, last night and today I tried to mount the card again to update music/videos to the card.

 

When I connect my phone/laptop via USB/data cable it shows up in the "Safely Remove Hardware" on the bottom task bar of the computer. It also shows a new drive in "My Computer" and I go to the notifications on my Eris and click on where it says the USB is connected. I hit "mount" and then it shows "Turn off USB storage device" and then it shows "Preparing microSD card" and then my Windows Explorer Panel pops up asking what I'd like to do with the newly detected device. I click "Open folder to view files" then it tells me "Please insert a disc in removable drive (J):"

 

Now, I've tried to uninstall and reinstall the drivers, the sync software from HTC's support section on their website etc and NOTHING works. I've spent hours, tonight alone, trying to fix this and can't figure it out. It's getting to the point where I'd rather pay $175 to cancel my contract to switch to the more user friendly and less headache causing iPhone. I've had the iPod touch before and it's easy as hell to transfer movies and music to that...if the Droid Eris is supposed to be VZW's "competitor" to the iPhone, then why is it such a headache?

 

I have tried every tip that has helped others resolve this issue and nothing's worked for me. I would greatly appreciate any and all help. I apologize for the length of this but  I wanted to make sure whoever is going to try to help doesn't waste their time by telling me "solutions" that I've already tried.

 

Thank you, in advance, for your help!

 

-Mike

Labels (1)
Tags (4)
0 Likes
Highlighted

Re: Trouble mounting my microSD card despite hours of troubleshooting.

Sr. Member
The phone should not immediately tell you that it is un-mounting the SD card. You aren't "double tapping" the "mount" option are you? If the phone is simply automatically turning off USB storage, there's a chance that the SD card is corrupted. The first thing I would try is going into the SD/Storage section in the phone, unmount, then format the card. (it will automatically re-mount) If that doesn't solve the issue I'd try doing a factory reset on the phone. If it still does this, it has got to be something with your PC causing the issues - try hooking it up to another computer and see if you can mount it properly, you do not need the HTC sync software on the machine to simply mount the SD card - Maybe it is the HTC software causing the issues. I've never messed with the HTC software, so I can't tell you. Also, if I remember correctly the ETF for smart phones is $350, not $175, although you have 30 days to return w/o paying ETF.
0 Likes