Highlighted

New Motor Z4 and bad service

Unique101
Member

I upgraded from Moto Z2play to the new Moto Z4. And the service has been awful barely 1 bar some days. No data at times and I'm on the beyond unlimited plan. I can be in another city and still poor service. I'm considering returning it for something else. 

Re: New Motor Z4 and bad service

Community Manager
Community Manager

Unique101, this is certainly not the service experience we want you to have with your brand new Motorola moto z4. Having a phone that meets your service needs is without question. After checking some resources, I don't see the moto z4 has any existing reported issues with service or signal. Are you mainly having issues indoors when you receive one signal bar?

 

Please reference the link attached to use our helpful online Verizon Troubleshooting Assistant. You can choose the option for "I can't connect to the internet" for various steps you can take. Please keep us posted as we want to ensure this service concern is resolved for you. http://spr.ly/6602Ev5Hk

 

 

AlanS_VZW

0 Likes

Re: New Motor Z4 and bad service

Rosemeyer99
Member

I'm having the same problem, I haupgraded from the z2 play to the z4 and most of the time inside and out, I have NO service. I have great service with the z2

Re: New Motor Z4 and bad service

Community Manager
Community Manager

I definitely understand the significant role our devices play in day-to-day life, and it would be difficult to be happy with anything that's not working. While we have been unable to duplicate this behavior in-house we do want to turn this experience around.

Linked here is a guide that will rule out some culprits.
https://www.verizonwireless.com/support/motorola-moto-z4-troubleshooting/#/main/device/&MOTXT19804W&...
Removing the SIM card and reinserting is where we’ll begin. What type of service are you seeing after that? Do you have other phones experiencing “No Service” where your moto z4 is?


DavidH_VZW

0 Likes

Re: New Motor Z4 and bad service

Nighthawk01
Member

I too have the same sensitivity problem.
I have my old Moto Z side by side with the new Z4 and I have Network Cell Info installed on each.
It's evening, 11:00 PM EDST.
Ellijay, GA 30536
My old Moto Z phone signal level is -92 dBm.
The new Z4 is measuring -107 dBm.
15 dBm is a HUGE difference.
I have never ever had a connectivity problem with the Moto Z.
I've had the Moto Z for almost 3 years.
I am having constant problems with the new Z4.
Not just the phone sensitivity but the WiFi drops out within site of the ASUS RT-AC88U Wireless-AC3100 Router.
I can wander around the vicinity of my home outside with the Moto Z, on WiFi with my Mom in Spain and live video. 
The Z4, not so.
I have a very real problem with this phone.

0 Likes

Re: New Motor Z4 and bad service

game2k7
Member

im have the same issues me and  3 others got a plan together and got the z4 and non of us get good signal verizon techs tell us well it cant be the phone if all 4 of u are having the same problem its got to be the tower so 4 phones that are 20 miles from the other phones are having the exact same tower issue suuuuuure but im waiting on ticket updates please just send a tech to my house with a a couple of phones that arent z4s and see they have the issue

 

 

Re: New Motor Z4 and bad service

Nighthawk01
Member

I have  my operational Moto Z Force Droidside side by side with the Z4.
The Moto Z Force Droid is 10 dB hotter
At this moment:
Moto Z Force Droid -91 dBm, RSSI
Moto Z4 -108 dBm RSSI

That's 17 dBm difference with the phones sitting inches apart.

That pretty well sums it up. Major flaw.

0 Likes