Highlighted

My Galaxy S5 wont stay connected to wifi

bonafidejonb
Member

It randomly connects and disconnects when in range of wifi...

Labels (1)
0 Likes
1 Solution

Correct Answers

Re: My Galaxy S5 wont stay connected to wifi

Cheyne6
Member

Have you tried the steps in my post above?

Go to Settings > Wi-Fi > Hit the menu key (3 dots in upper right) > Advanced > Turn off 'Smart network switch'.


This fixed my issue and has been steady for about 30 minutes (ish) now. Let me know if it helps.

View solution in original post

Re: My Galaxy S5 wont stay connected to wifi

Snn5
Sr. Leader

Did you receive the 5.0 update?  Did it start then if so?  Have you "forgotten" the network within wifi settings and tried to add it?  Rebooted router?  Have you factory reset the device after the 5.0 update if you did install it?  Does this happen at random or when the device has been asleep or unused for a while?  Are WiFi settings set to stay awake when phone is idle?  Are your battery save mode settings enabled and turning off WiFi to save power?

0 Likes

Re: My Galaxy S5 wont stay connected to wifi

bonafidejonb
Member

I didnt realize there was a 5.0 out...I am downloading that now...I have tried to "forget" the network and rebooted the router...

its not so random, but when i am more than 10 feet away from the router, it has a hard time staying connected...while all of my other devices (computer included) are over 10 feet away from the router and work fine...

Re: My Galaxy S5 wont stay connected to wifi

Community Manager
Community Manager

bonafidejonb,

I can understand how this issue would be inconvenient.  I noticed that you said you're currently downloading the latest update.  Please let us know how it goes once you test after the update! Thanks


TrevorCV_ZW

Follow us on Twitter @VZWSupport

0 Likes

Re: My Galaxy S5 wont stay connected to wifi

Cheyne6
Member

Hey bonafide. I have been receiving a similar error. I would be connected, it would drop, reconnect constantly every several seconds. I believe it was before and after the 5.0 update but I just noticed it yesterday after I updated. Today, I looked at the settings and I believe I may have found a fix (working for me for about 10 minutes anyway). Go to Settings > Wi-Fi > Hit the menu key (3 dots in upper right) > Advanced > Turn off 'Smart network switch'. So far it seems the Smart network switch feature isn't very smart. Hopefully they get this fixed but since I've done this, I haven't had any issues. Hope that works for you!

Re: My Galaxy S5 wont stay connected to wifi

Snn5
Sr. Leader

The Smart Switch was designed for improved battery life.

0 Likes

Re: My Galaxy S5 wont stay connected to wifi

Cheyne6
Member

That may be true but the tooltip for the option says it's "to maintain a stable Internet connection." To me, that means it's looking for a stronger connection and switches if the other is better. It was switching for me literally every few seconds on both my home wifi and the wifi at my office. Plus, when I disabled the option, my problem went away. Does consistently switching between the networks not do more harm than good for a battery?

Re: My Galaxy S5 wont stay connected to wifi

pwolke
Member

Similar issue with staying connected to WiFi. I've noticed a bunch of thread on this topic and picked this one to add my details to. I have a Samsung S5 and just updated to Lollipop the other day. Since then, have had an issue - the phone keeps reconnecting to WiFi. This happens across a few networks (home and work). I've restarted my phone a few times. I've reset the network in my house a few times. I've tried modifying my home network wireless settings (as some other forums have suggested that particular channels are at issue). I've tried "forgetting" the network on my phone and adding it again. Are there any other steps that VZW can recommend trying? Is it going to be a waiting game for an OS update to address the issue?

Re: My Galaxy S5 wont stay connected to wifi

Cheyne6
Member

Have you tried the steps in my post above?

Go to Settings > Wi-Fi > Hit the menu key (3 dots in upper right) > Advanced > Turn off 'Smart network switch'.


This fixed my issue and has been steady for about 30 minutes (ish) now. Let me know if it helps.

View solution in original post

Re: My Galaxy S5 wont stay connected to wifi

Snn5
Sr. Leader

Yes.  If the phone is constantly scanning for a network, it will use more battery.

0 Likes