Moto Z Droid voice-to-text doesn't work?

Member

I just upgraded to a Moto Z Droid and I'm not sure whats going on. I don't see a microphone on the default keyboard at all, and when I installed the Hackers Keyboard the microphone key doesn't work. I've looked online and most people having this problem with other phones find that there is a checkbox unchecked for the voice input setting, but the settings menu on this model doesn't appear to have that setting. How do I get it working so that when I'm chatting on Facebook or Texting I can hit the mic, say what I want, and it types it? OK Google works.

Labels (1)
0 Likes
1 Solution

Correct Answers

Re: Moto Z Droid voice-to-text doesn't work?

Sr. Member

Yes, sorry, I misunderstood the problem. Did you get it working? And did holding on the spot where the microphone used to be on the keyboard help any? If not, I had some other steps to try:

Make sure the voice input key is turned on:

- Settings > Language & input > Google keyboard > Preferences > Voice input key

 

While in those Google keyboard settings, also make sure that "Google Voice Typing" and "Google Keyboard" are both set to the same language.

 

If all of that checks out, then try clearing data for Google Voice:

- Settings > Apps > Google Voice (May need to tap the three dots on the top-right and select "Show system" for this to appear > Google Voice > Clear Cache

- If that doesn't fix it, do the same, but try "Clear Data" instead of "Clear Cache" and restart afterwards.

View solution in original post

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Sr. Member

On the default keyboard, do you see a different icon where you would normally see the microphone, like an emoticon (smiley face) or a settings (gear) icon? If so, you should be able to press and hold on that to open a menu of icons for that spot, which should include the microphone.

If that doesn't work, try going to Settings > Accessibility > Text-to-speech output.

Verify that Google Text-to-speech Engine is selected there.

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Member

I have it checked but that's the opposite of what I want, I need speech to

text so I can dictate messages. It worked on my galaxy.

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Member

Ok figured it out, its under languages & inputs > virtual keyboards >

manage keyboards > google voice typing that's where the option is now.

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Sr. Member

Yes, sorry, I misunderstood the problem. Did you get it working? And did holding on the spot where the microphone used to be on the keyboard help any? If not, I had some other steps to try:

Make sure the voice input key is turned on:

- Settings > Language & input > Google keyboard > Preferences > Voice input key

 

While in those Google keyboard settings, also make sure that "Google Voice Typing" and "Google Keyboard" are both set to the same language.

 

If all of that checks out, then try clearing data for Google Voice:

- Settings > Apps > Google Voice (May need to tap the three dots on the top-right and select "Show system" for this to appear > Google Voice > Clear Cache

- If that doesn't fix it, do the same, but try "Clear Data" instead of "Clear Cache" and restart afterwards.

View solution in original post

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Member

I'm having the same problem. I've done all the fixes EXCEPT clear the cache because "google voice" isn't under apps, even after hitting 3 dots in upper right corner to show system. It seems it's just disappeared. The whole bar above keyboard where that would be, predictive text, ect is just gone since 4 days ago after system update. 

0 Likes

Re: Moto Z Droid voice-to-text doesn't work?

Moderator
Moderator

Due to the age of this thread, it will be locked in order to keep discussions current. If you have the same or a similar question/issue we invite you to start a new thread on the topic.

0 Likes