LG V20 Stuck in system update loop

angelsix
Member

My LG V20 keeps reinstalling the latest system updates (apparently there are two).  Goes through the whole process, apparently A-OK, re-boots, then tells me there's a new system update and starts downloading it again.  Help?

Bonus question:  Since this process started, my phone occasionally says, for no good reason, "Verizon".  I don't see a Verizon app

Labels (1)
0 Likes

Re: LG V20 Stuck in system update loop

angelsix
Member

YEA!  This morning I got the message "System Update Complete".  Checking the System App under updates ("Check for System Update") it now says "No New System Update Available   Your LG VS995 is up to date.  No update is necessary at this time."  I'm glad that problem is solved.  As is often the case, I have no idea why the update failed numerous times previously and then succeeded this time.  My guess is that Verizon noticed that I (and, probably, others) was having this problem, and tweaked the update.

As to the "Bonus question", my phone is still occasionally saying, through the speaker, "Verizon Wireless" at random times.  I'm hopeful that problem will go away too.

0 Likes

Re: LG V20 Stuck in system update loop

angelsix
Member

Maybe I've found a solution to the bonus question too.  Did a search and found that this problem has been around for a long time (e.g., found a 2012 question from someone with a Droid2 having the same issue).  Apparently the problem can be triggered by a System Update, and, fixed by turning off the "Sound When Roaming".  I'm not roaming when the problem happens, but I get weak Verizon signal at my home, so I think my phone is celebrating that I'm back in the welcoming arms of the Verizon network with the announcement "Verizon network." If I were somewhere where I was worried about roaming charges, I'd like more nuanced warning system than just having the name of whatever network my phone is picking up be announced out loud.

Sometimes settings get changed when phones are updated; has your phone received a recent update?  The exact path may be different, but have you gone to Settings > Sound > Sound Effects > Sound When Roaming and ensured it's off?

0 Likes