Re: Invalid server certificate (Comcast)

bobandsherry
Member

Same problem as well - now 2 days in the running.  I finally did it the hard way, went into my email account (under Settings -> Manage Accounts) and deleted data.  I removed the account as well.  Added account back, then initially had problems with it telling me I had "Incorrect username or password", which I know very well it's not incorrect username or password as I log into Comcast account daily - and used same login/password on comcast just now without any issue. After about 10 minutes I started to get email once again (though I still was seeing the invalid username or password error message).  That finally cleared itself up as well and mail is now syncing up once again.

 

My thought on this, and why I deleted the email account and data is Comcast must have been screwing around with some of their mail servers and ended up with change in their certificate. Removing and adding the account back would force the certificate info to be reset.  Don't know if that's correct thought but it's working now and it wasn't just a few minutes before.

0 Likes

Re: Invalid server certificate (Comcast)

tripdip
Member

I believe I am cured!?

 

I talked to Verizon Tech Support, speaking with several levels of support and ultimately they indicated it was not an issue on their end (not surprised...).  They did provide some new Port numbers and said that Comcast told them they were revised and more specific to my model (Droid2).

 

They then referred me to Comcast and said that I should review my settings with them to ensure all ports and other settings were correct to satisfy Comcast's email system.

Reluctently I contacted Comcast Tech support and went through 4 people until I finally reached a guy who worked with me to resolve the problem.  I seemed to have issues with Incoming mail only and here is what I was told and what worked:

 

There are standard port settings and then there are "alternative" settings.  Coincidentally the alternative settings were the same as those that Verizon provided.

 

The standard port settings are: Incoming=110, Outgoing=587.

If you use these settings, under Advanced Settings you should Uncheck the box for "Use Secure Connection".  You should also, Uncheck the box for "Verify Certificate".

 

The alternative port settings are: Incoming=995, Outgoing=465.

If you use these settings, you should Check the box for "Use Secure Connection", but leave the "Verify Certificate" box Unchecked.

 

I have multiple Comcast accounts and tried it both ways.  They both allowed my email to flow properly, inbound and outbound.

 

My only concern was why this suddenly became and issue (he had no clue) and why I would not want the "Verify Certificate" box checked.  He put me on hold and checked with other support personnel to reconfirm this.  He said that he and none of his colleagues had ever checked this box when setting up an account or troubleshooting an account.  Other than that lukewarm confirmation, he could not provide any further clarity.

 

Bottom line is, these settings resolved the mail flow issue, but did not fully satisfy my security concerns...

0 Likes

Re: Invalid server certificate (Comcast)

tripdip
Member

Re: Bobandsherry post just before my last post

I had a brief period today, when I received messages and it lasted for less than 30 minutes.  Then the errors came back and all incoming mail stopped until I got home and pursued tech support from both Verizon and Comcast.

So, I would be interested to know if your incoming issues remain resolved or if it reoccurs as mine did.

 

thanks

0 Likes

Re: Invalid server certificate (Comcast)

jcerulo
Member

I am have the same problem.  I keep getting an "invalid server certificate when my email comes in. Started happening last week.

Invalid server certificate. [org.bouncycastle.jce exception.

ExtCertPathValidatorException: Could not validate certificate signature.]

 

How do we fix it???

 

0 Likes

Re: Invalid server certificate (Comcast)

blinTN
Member

Tripdip: Thank you for posting this solution.  I tried changing the settings as you suggested, and so far I am able to retrieve my e-mail with my Droid 2 after several days of frustration with an "on again-off again" situation.  I'm glad to know I wasn't the only person experiencing this.  I am blaming Comcast, not Verizon.

0 Likes

Re: Invalid server certificate (Comcast)

Dayzeemay
Member

Just wanted to add that my husband and myself tried something today, similar to what Tripdip posted.

 

Check the settings and disregard the last two steps including the roaming setting in step 3.

 

Step 1

Enter the "Settings" screen, and select "Wireless & Networks."

Step 2

Select "Mobile networks" > "System Select." Verify that "Automatic" is selected.

Step 3

Enter the "Settings" screen, and select "Data Manager." Select "Data Delivery." Verify the following settings are active: Background Data, Data Roaming and Data Enabled.

Step 4

Enter the "Settings" screen, and go into the "Accounts" screen. Configure the "Outgoing Server" settings. Enter "smtp.comcast.net" into the "SMTP Server" text box. Enter "587" into the "Port" text box. Enter your Comcast username and password into the appropriate boxes. Verify the "Use secure connection" is set to "OFF." Verify the "Certificate" is OFF.

Step 5

Enter the "Settings" screen, and go into the "Accounts" screen. Configure the "Incoming Server" settings. Enter "mail.comcast.net" into the "SMTP Server" text box. Enter "995" into the "Port" text box. Enter your Comcast username and password into the appropriate boxes. Verify the "Use secure connection" is set to "ON."

Step 6

Shut the phone off, wait 20 seconds, and power it back on.

Step 7

Dial "*288" and select option 2 from the list. This will update your roaming.

Step 8

Verify your Comcast email works properly.

 

We made these changes around noon today and were very happy that it seemed to be fixed. 

 

Unfortunately it was short lived.  It is now 8:00 pm and our problem has started again. 

 

I hope an alternative solution is found soon.  This really bites.........:smileymad:

 

0 Likes

Re: Invalid server certificate (Comcast)

Lholland
Member

Husband and I are having the same problems!   Droid 2s.

0 Likes
Highlighted

Re: Invalid server certificate (Comcast)

cstephens
Member

I'm having the same problem on my Droid 3, but it's with my Yahoo and Corporate email accounts. I don't think the problem was with Comcast changing anything because I'm having the same problem with a different email service provider. I suspect it's on VZW's end for it to be an issue on multiple SPs?

0 Likes